summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--0004-HID-wacom-Correct-NULL-dereference-on-AES-pen-proxim.patch76
-rw-r--r--PKGBUILD12
3 files changed, 12 insertions, 92 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cd257624d45..e70af8ab86ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-rc
- pkgver = 5.10.11rc2
+ pkgver = 5.10.12rc1
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -12,26 +12,24 @@ pkgbase = linux-rc
makedepends = tar
makedepends = xz
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.10.11-rc2.xz
- source = https://www.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.10.11-rc2.sign
- source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.10.10.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.10.10.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.10.12-rc1.xz
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/stable-review/patch-5.10.12-rc1.sign
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.10.11.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.10.11.tar.sign
source = config
source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
source = 0002-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_sp.patch
source = 0003-iwlwifi-Fix-regression-from-UDP-segmentation-support.patch
- source = 0004-HID-wacom-Correct-NULL-dereference-on-AES-pen-proxim.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- b2sums = bd792d7dfdb393809ce476b7e1c11c4ab92f078d47cb6b7a2b52543eadac127605c7854a5bd310a011592d3de020a42a46c974fe2738f9af46bf9f33637254c3
+ b2sums = e7d5014a80ca23db3b84f4a3217bc69a5fc6b1fc08f3c756106046a016968824962de64385a437f3bdc3c1b9bfa1c55beb5fe3cb30c7469bfc59f0dd1d398be5
b2sums = SKIP
- b2sums = 180f0dd063eab9542fd799c54dd335c4f310bea739048800ab3222526cb1ea7cc4ef43d2a2c27ed0e37a776f5c77540c33795aa63297704d9e215735a1a98606
+ b2sums = f2ffb77efeab44e5ac74f275f1c728618a0893c752018946a3908a34dca2797982efb6646df1350f31c9cab2b780aca871dff82b63e2ec59e3bfcdafa0457581
b2sums = SKIP
b2sums = cb3a58e4eef8395b75887d94a84bba25f05fbec8f576a791623057a190a1d51b412a19ecf1b600ac3f9f6c46968eb0e130d571743e61afc231a97146ee4b52d0
b2sums = de81e92b92ba697e472d6397faa425ebcc09bede6c97008dcae47efd341d2eaa12ec72209c4cc97155df01358e1fce3a86d3f0b5441ac91615037de72105defc
b2sums = 9450bd3d4acfa94723eaf22f2c0a13ae3bdb1ceb15ad19d1a1de2fc8d9a7b9b8f759006fd5b4286da135c68bac75791b4bf767ece8b6c40aff95799296ee0327
b2sums = ea8e11fa3e9ccffe26366c2c279e11ffd4cb7ed0500028afef083188d46a0df2487800417914e63b8ac101b6a28b6a61aad91bea0b7a0305d64be3445a4f68a0
- b2sums = b57086457843e75899772ec37a469f524d7f5df5a1ba27ab35a97b478ed37b8deb29371db3f69b33ec10eaf38fd554cef0da7c64c451b11db84e4dc497f8bae9
pkgname = linux-rc
pkgdesc = The release candidate kernel and modules
diff --git a/0004-HID-wacom-Correct-NULL-dereference-on-AES-pen-proxim.patch b/0004-HID-wacom-Correct-NULL-dereference-on-AES-pen-proxim.patch
deleted file mode 100644
index a5d00ca938f6..000000000000
--- a/0004-HID-wacom-Correct-NULL-dereference-on-AES-pen-proxim.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From 85c0c0e3a81f87290db5e881af609d51021b54b7 Mon Sep 17 00:00:00 2001
-From: Jason Gerecke <killertofu@gmail.com>
-Date: Thu, 21 Jan 2021 10:46:49 -0800
-Subject: [PATCH 4/5] HID: wacom: Correct NULL dereference on AES pen proximity
-
-The recent commit to fix a memory leak introduced an inadvertant NULL
-pointer dereference. The `wacom_wac->pen_fifo` variable was never
-intialized, resuling in a crash whenever functions tried to use it.
-Since the FIFO is only used by AES pens (to buffer events from pen
-proximity until the hardware reports the pen serial number) this would
-have been easily overlooked without testing an AES device.
-
-This patch converts `wacom_wac->pen_fifo` over to a pointer (since the
-call to `devres_alloc` allocates memory for us) and ensures that we assign
-it to point to the allocated and initalized `pen_fifo` before the function
-returns.
-
-Link: https://github.com/linuxwacom/input-wacom/issues/230
-Fixes: 37309f47e2f5 ("HID: wacom: Fix memory leakage caused by kfifo_alloc")
-CC: stable@vger.kernel.org # v4.19+
-Signed-off-by: Jason Gerecke <jason.gerecke@wacom.com>
-Tested-by: Ping Cheng <ping.cheng@wacom.com>
----
- drivers/hid/wacom_sys.c | 7 ++++---
- drivers/hid/wacom_wac.h | 2 +-
- 2 files changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/drivers/hid/wacom_sys.c b/drivers/hid/wacom_sys.c
-index 9e852b4bbf92..73dafa60080f 100644
---- a/drivers/hid/wacom_sys.c
-+++ b/drivers/hid/wacom_sys.c
-@@ -147,9 +147,9 @@ static int wacom_wac_pen_serial_enforce(struct hid_device *hdev,
- }
-
- if (flush)
-- wacom_wac_queue_flush(hdev, &wacom_wac->pen_fifo);
-+ wacom_wac_queue_flush(hdev, wacom_wac->pen_fifo);
- else if (insert)
-- wacom_wac_queue_insert(hdev, &wacom_wac->pen_fifo,
-+ wacom_wac_queue_insert(hdev, wacom_wac->pen_fifo,
- raw_data, report_size);
-
- return insert && !flush;
-@@ -1280,7 +1280,7 @@ static void wacom_devm_kfifo_release(struct device *dev, void *res)
- static int wacom_devm_kfifo_alloc(struct wacom *wacom)
- {
- struct wacom_wac *wacom_wac = &wacom->wacom_wac;
-- struct kfifo_rec_ptr_2 *pen_fifo = &wacom_wac->pen_fifo;
-+ struct kfifo_rec_ptr_2 *pen_fifo;
- int error;
-
- pen_fifo = devres_alloc(wacom_devm_kfifo_release,
-@@ -1297,6 +1297,7 @@ static int wacom_devm_kfifo_alloc(struct wacom *wacom)
- }
-
- devres_add(&wacom->hdev->dev, pen_fifo);
-+ wacom_wac->pen_fifo = pen_fifo;
-
- return 0;
- }
-diff --git a/drivers/hid/wacom_wac.h b/drivers/hid/wacom_wac.h
-index da612b6e9c77..195910dd2154 100644
---- a/drivers/hid/wacom_wac.h
-+++ b/drivers/hid/wacom_wac.h
-@@ -342,7 +342,7 @@ struct wacom_wac {
- struct input_dev *pen_input;
- struct input_dev *touch_input;
- struct input_dev *pad_input;
-- struct kfifo_rec_ptr_2 pen_fifo;
-+ struct kfifo_rec_ptr_2 *pen_fifo;
- int pid;
- int num_contacts_left;
- u8 bt_features;
---
-2.30.0
-
diff --git a/PKGBUILD b/PKGBUILD
index ec1684e1eff3..69d36aac7176 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@ _srcname=linux-5.10
_major=5.10
### on initial release this is null otherwise it is the current stable subversion
### ie 1,2,3 corresponding $_major.1, $_major.3 etc
-_minor=10
+_minor=11
_minorc=$((_minor+1))
### on initial release this is just $_major
_fullver=$_major.$_minor
#_fullver=$_major
-_rcver=2
+_rcver=1
_rcpatch=patch-${_major}.${_minorc}-rc${_rcver}
pkgver=${_major}.${_minorc}rc${_rcver}
arch=(x86_64)
@@ -32,21 +32,19 @@ source=(
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_sp.patch
0003-iwlwifi-Fix-regression-from-UDP-segmentation-support.patch
- 0004-HID-wacom-Correct-NULL-dereference-on-AES-pen-proxim.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-b2sums=('bd792d7dfdb393809ce476b7e1c11c4ab92f078d47cb6b7a2b52543eadac127605c7854a5bd310a011592d3de020a42a46c974fe2738f9af46bf9f33637254c3'
+b2sums=('e7d5014a80ca23db3b84f4a3217bc69a5fc6b1fc08f3c756106046a016968824962de64385a437f3bdc3c1b9bfa1c55beb5fe3cb30c7469bfc59f0dd1d398be5'
'SKIP'
- '180f0dd063eab9542fd799c54dd335c4f310bea739048800ab3222526cb1ea7cc4ef43d2a2c27ed0e37a776f5c77540c33795aa63297704d9e215735a1a98606'
+ 'f2ffb77efeab44e5ac74f275f1c728618a0893c752018946a3908a34dca2797982efb6646df1350f31c9cab2b780aca871dff82b63e2ec59e3bfcdafa0457581'
'SKIP'
'cb3a58e4eef8395b75887d94a84bba25f05fbec8f576a791623057a190a1d51b412a19ecf1b600ac3f9f6c46968eb0e130d571743e61afc231a97146ee4b52d0'
'de81e92b92ba697e472d6397faa425ebcc09bede6c97008dcae47efd341d2eaa12ec72209c4cc97155df01358e1fce3a86d3f0b5441ac91615037de72105defc'
'9450bd3d4acfa94723eaf22f2c0a13ae3bdb1ceb15ad19d1a1de2fc8d9a7b9b8f759006fd5b4286da135c68bac75791b4bf767ece8b6c40aff95799296ee0327'
- 'ea8e11fa3e9ccffe26366c2c279e11ffd4cb7ed0500028afef083188d46a0df2487800417914e63b8ac101b6a28b6a61aad91bea0b7a0305d64be3445a4f68a0'
- 'b57086457843e75899772ec37a469f524d7f5df5a1ba27ab35a97b478ed37b8deb29371db3f69b33ec10eaf38fd554cef0da7c64c451b11db84e4dc497f8bae9')
+ 'ea8e11fa3e9ccffe26366c2c279e11ffd4cb7ed0500028afef083188d46a0df2487800417914e63b8ac101b6a28b6a61aad91bea0b7a0305d64be3445a4f68a0')
export KBUILD_BUILD_HOST=archlinux