summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1ccdc14c97d..080b077cbbe9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,7 @@
pkgbase = linux-rt-bfq
+ pkgdesc = Linux RT-BFQ-dev
pkgver = 5.2.21.rt13
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/sirlucjan/bfq-mq-lucjan
arch = x86_64
license = GPL2
@@ -40,7 +41,7 @@ pkgbase = linux-rt-bfq
sha512sums = 8f6cdf859cf1c712749de734bb9ad5769ff03e2c426cdc3adad8db91adc447e8ca050d7752b30108363330e4b6ad881330c4dbcfdf357e87c6848dae409ef1f4
pkgname = linux-rt-bfq
- pkgdesc = The Linux-rt-bfq kernel and modules with the RT patch.
+ pkgdesc = The Linux RT-BFQ-dev kernel and modules
depends = coreutils
depends = kmod
depends = initramfs
@@ -49,10 +50,10 @@ pkgname = linux-rt-bfq
optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
pkgname = linux-rt-bfq-headers
- pkgdesc = Header files and scripts for building modules for Linux-rt-bfq kernel
+ pkgdesc = Headers and scripts for building modules for the Linux RT-BFQ-dev kernel
depends = linux-rt-bfq
pkgname = linux-rt-bfq-docs
- pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-rt-bfq kernel
+ pkgdesc = Kernel hacker's manual for the Linux RT-BFQ-dev kernel
depends = linux-rt-bfq
diff --git a/PKGBUILD b/PKGBUILD
index 6bf2acff114e..5bc71724078e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,8 @@ _rtpatchver=rt${_rtver}
pkgver=${_major}.${_minor}.${_rtpatchver}
_pkgver=${_major}.${_minor}
_srcname=linux-${_pkgver}
-pkgrel=5
+pkgrel=6
+pkgdesc='Linux RT-BFQ-dev'
arch=('x86_64')
url="https://github.com/sirlucjan/bfq-mq-lucjan"
license=('GPL2')
@@ -198,7 +199,7 @@ build() {
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the RT patch."
+ pkgdesc="The $pkgdesc kernel and modules"
depends=('coreutils' 'kmod' 'initramfs')
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices'
@@ -227,7 +228,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=('linux-rt-bfq')
cd $_srcname
@@ -309,7 +310,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the ${pkgbase/linux/Linux} kernel"
+ pkgdesc="Kernel hacker's manual for the $pkgdesc kernel"
depends=('linux-rt-bfq')
cd $_srcname
@@ -319,8 +320,8 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
+ msg2 "Removing unneeded files..."
+ rm -rv "$builddir"/Documentation/{,output/}.[^.]*
msg2 "Moving HTML docs..."
local src dst