summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 4 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89c5e6a9f1de..a6aecc4d6631 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-rt-bfq
pkgver = 4.19.31.rt18
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Algodev-github/bfq-mq/
arch = x86_64
license = GPL2
@@ -8,8 +8,6 @@ pkgbase = linux-rt-bfq
makedepends = inetutils
makedepends = bc
makedepends = libelf
- makedepends = python-sphinx
- makedepends = graphviz
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.31.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.19.31.tar.sign
diff --git a/PKGBUILD b/PKGBUILD
index c46bd8cc57c0..2e9dfc540379 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,12 +57,12 @@ _rtpatchver=rt${_rtver}
pkgver=${_major}.${_minor}.${_rtpatchver}
_pkgver=${_major}.${_minor}
_srcname=linux-${_pkgver}
-pkgrel=3
+pkgrel=4
arch=('x86_64')
url="https://github.com/Algodev-github/bfq-mq/"
license=('GPL2')
options=('!strip')
-makedepends=('kmod' 'inetutils' 'bc' 'libelf' 'python-sphinx' 'graphviz')
+makedepends=('kmod' 'inetutils' 'bc' 'libelf')
_bfq_sq_mq_path="bfq-sq-mq"
_bfq_sq_mq_ver='v10r1'
_bfq_sq_mq_rel='2K190411-rc1'
@@ -203,7 +203,7 @@ prepare() {
build() {
cd ${_srcname}
- make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -358,18 +358,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"