summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
-rw-r--r--fix_CPU0_microcode_on_resume.patch21
3 files changed, 38 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41664c06ffe7..62c61e418442 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-selinux
- pkgver = 3.17.2
+ pkgver = 3.17.3
pkgrel = 1
url = http://www.kernel.org/
arch = i686
@@ -13,17 +13,19 @@ pkgbase = linux-selinux
makedepends = bc
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v3.x/linux-3.17.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v3.x/patch-3.17.2.xz
+ source = https://www.kernel.org/pub/linux/kernel/v3.x/patch-3.17.3.xz
source = config
source = config.x86_64
source = linux-selinux.preset
source = change-default-console-loglevel.patch
+ source = fix_CPU0_microcode_on_resume.patch
sha256sums = f5153ec93c5fcd41b247950e6a9bcbc63fa87beafd112c133a622439a0f76251
- sha256sums = 4576c30a46c016502cdd007d28dde4f2d141c0f8096be8623a9ff519323db777
+ sha256sums = 3c1ba3cc89d0f2d5f7303f448495f64db1ab96efea5f5fdd4b4c8c547600f85d
sha256sums = 1331d1b35309c8905ab53c82204580bd7c74d5aac11c8e29fe27e6c4b50399e0
sha256sums = 0dd66b478fcaa8f0ce88debf4681443b82336445af2215b87f186ac8f2a9ff48
sha256sums = 375da3b030f17581cbf5be9140b79029ca85eebc70197f419a4de77e00fa84e9
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
+ sha256sums = 43668fe46147fe93f41b919db673574427ce5a8c376cd28ddddcbf3a00326491
pkgname = linux-selinux
pkgdesc = The Linux-selinux kernel and modules
@@ -34,20 +36,20 @@ pkgname = linux-selinux
depends = kmod
depends = mkinitcpio>=0.7
optdepends = crda: to set the correct wireless channels of your country
- provides = kernel26-selinux=3.17.2
+ provides = kernel26-selinux=3.17.3
conflicts = kernel26-selinux
replaces = kernel26-selinux
backup = etc/mkinitcpio.d/linux-selinux.preset
pkgname = linux-selinux-headers
pkgdesc = Header files and scripts for building modules for Linux-selinux kernel
- provides = kernel26-selinux-headers=3.17.2
+ provides = kernel26-selinux-headers=3.17.3
conflicts = kernel26-selinux-headers
replaces = kernel26-selinux-headers
pkgname = linux-selinux-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-selinux kernel
- provides = kernel26-selinux-docs=3.17.2
+ provides = kernel26-selinux-docs=3.17.3
conflicts = kernel26-selinux-docs
replaces = kernel26-selinux-docs
diff --git a/PKGBUILD b/PKGBUILD
index 87cae58667e5..b1f5f5b54a59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=linux-selinux
_srcname=linux-3.17
-pkgver=3.17.2
+pkgver=3.17.3
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
@@ -20,13 +20,15 @@ source=("https://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux-selinux.preset'
'change-default-console-loglevel.patch'
+ 'fix_CPU0_microcode_on_resume.patch'
)
sha256sums=('f5153ec93c5fcd41b247950e6a9bcbc63fa87beafd112c133a622439a0f76251'
- '4576c30a46c016502cdd007d28dde4f2d141c0f8096be8623a9ff519323db777'
+ '3c1ba3cc89d0f2d5f7303f448495f64db1ab96efea5f5fdd4b4c8c547600f85d'
'1331d1b35309c8905ab53c82204580bd7c74d5aac11c8e29fe27e6c4b50399e0'
'0dd66b478fcaa8f0ce88debf4681443b82336445af2215b87f186ac8f2a9ff48'
'375da3b030f17581cbf5be9140b79029ca85eebc70197f419a4de77e00fa84e9'
- '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
+ '1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
+ '43668fe46147fe93f41b919db673574427ce5a8c376cd28ddddcbf3a00326491')
_kernelname=${pkgbase#linux}
@@ -44,6 +46,10 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -p1 -i "${srcdir}/change-default-console-loglevel.patch"
+ # Fix FS#42689
+ # https://bugzilla.kernel.org/show_bug.cgi?id=88001
+ patch -p1 -i "${srcdir}/fix_CPU0_microcode_on_resume.patch"
+
if [ "${CARCH}" = "x86_64" ]; then
cat "${srcdir}/config.x86_64" > ./.config
else
diff --git a/fix_CPU0_microcode_on_resume.patch b/fix_CPU0_microcode_on_resume.patch
new file mode 100644
index 000000000000..56f8094fd66c
--- /dev/null
+++ b/fix_CPU0_microcode_on_resume.patch
@@ -0,0 +1,21 @@
+diff --git a/arch/x86/kernel/cpu/microcode/core.c b/arch/x86/kernel/cpu/microcode/core.c
+index dd9d6190b08d..181e42bd85d3 100644
+--- a/arch/x86/kernel/cpu/microcode/core.c
++++ b/arch/x86/kernel/cpu/microcode/core.c
+@@ -85,6 +85,7 @@
+ #include <linux/syscore_ops.h>
+
+ #include <asm/microcode.h>
++#include <asm/microcode_intel.h>
+ #include <asm/processor.h>
+ #include <asm/cpu_device_id.h>
+ #include <asm/perf_event.h>
+@@ -465,6 +466,8 @@ static void mc_bp_resume(void)
+
+ if (uci->valid && uci->mc)
+ microcode_ops->apply_microcode(cpu);
++ else if (!uci->mc)
++ load_ucode_intel_ap();
+ }
+
+ static struct syscore_ops mc_syscore_ops = {