summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD17
-rw-r--r--fix-ck-broken-sleep2ram-5.4.48+.patch31
2 files changed, 40 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7279d48459d6..2b78b17c5874 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# https://www.kernel.org/category/releases.html
# 5.4 Greg Kroah-Hartman & Sasha Levin 2019-11-24 Dec, 2021
_LLL_VER=5.4
-_LLL_SUBVER=62
+_LLL_SUBVER=64
# Bisect debug, v5.4.47 -> v5.4.48
_Bisect_debug=off # on, test, off
@@ -74,11 +74,11 @@ source=(
'sphinx-workaround.patch'
'ck-patch-for-5.4.57+.patch'
'ck-patch-for-5.4.62+.patch'
+ 'fix-ck-broken-sleep2ram-5.4.48+.patch::https://github.com/zen-kernel/zen-kernel/commit/fb7e2cfaf61cf5f9c2336331e73296f455bd2d51.patch'
'uksm-patch-for-5.4.33+.patch'
'linux-cjktty-patch-for-5.4.36+.patch'
'linux-cjktty-patch-for-5.4.54+.patch'
'linux-cjktty-patch-for-5.4.62+.patch'
- 'broken-sleep-5.4.48+.patch::https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/patch/?id=f7757368e0f0b3e108088ca7b5b8abda6faa7ebc'
'config' # the main kernel config file
'60-linux.hook' # pacman hook for depmod
'90-linux.hook' # pacman hook for initramfs regeneration
@@ -91,7 +91,7 @@ validpgpkeys=(
# https://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
sha256sums=('bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491'
'SKIP'
- '9ce992afb4893a88c25d8dada043690d356176cca0d943091d5e2f2fcd856008'
+ '01ceb94f15a8e1877cc10b85179f2f1e6fafdede793c53e8a0b75771e9769a53'
'f445eea4d0ec2015a25f1ad625c848f4f2252099795966fa4105e0aa29674c5c'
'81d34bf02e771a126af5cb382d44a86dcc759c88b7c89fc7e5b7737731b9130e'
'50213f3270499fceb452946252d61f5471571c77baf3dd510fbb00cfa9831c9a'
@@ -99,11 +99,11 @@ sha256sums=('bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491'
'b7c814c8183e4645947a6dcc3cbf80431de8a8fd4e895b780f9a5fd92f82cb8e'
'a10a4848c7a9842c0c7760b087ea38a4356dc1a2c2e26334cb0106c25785554f'
'0334391900f31d6aaedaa68e8917f93262ba3e523f2654774b289e9b18c1a923'
+ '961ed94b8d905f1e901cacb08d253c4170af0a25828111b7558d9c874e923558'
'6826624f65276927de012f040e77b02231fe6345b9da7c702deacd9372ea001e'
'573f1c40951a6ee4cf6b07a6a8a1123b00fcd8bff29843905cf191e08f1d87f2'
'2c9faabb5e09b1f818b051ced3eb90b6c04aa08616952d99eedf328c7c8dda2f'
'4d511fb62966549b9ea4a1d97769f79e4d66fc141cd0b001e7d286367a038a09'
- '9f9ec5becca27bc7b65b372254bcd4c64069deff1d3b7fa15e6e416595163654'
'7ce388e429d8df479a721285e445e116c5ee41e3126a702862e59056460b655e'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
@@ -130,10 +130,6 @@ prepare() {
fi
patch -p1 -i "${srcdir}/../v${pkgver}-${pkgrel}-$_bcommit"
fi
- # Bisect debug result
- if [ "$_Bisect_debug" != "on" ]; then
- patch -R -p1 -i "../broken-sleep-5.4.48+.patch"
- fi
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
@@ -146,6 +142,11 @@ prepare() {
patch -i ../ck-patch-for-5.4.57+.patch "../patch-${_LLL_VER}.${_LLL_SUBVER}-ck${_CK_VER}"
patch -i ../ck-patch-for-5.4.62+.patch "../patch-${_LLL_VER}.${_LLL_SUBVER}-ck${_CK_VER}"
patch -Np1 -i "../patch-${_LLL_VER}.${_LLL_SUBVER}-ck${_CK_VER}"
+ # Bisect debug result about ck
+ if [ "$_Bisect_debug" != "on" ]; then
+ #see https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/patch/?id=f7757368e0f0b3e108088ca7b5b8abda6faa7ebc
+ patch -p1 -i "../fix-ck-broken-sleep2ram-5.4.48+.patch"
+ fi
msg "Patching source with uksm ${_UKSM_VER} patches"
cp "../uksm-${_LLL_VER}.patch" "../uksm-${_LLL_VER}.${_LLL_SUBVER}.patch"
diff --git a/fix-ck-broken-sleep2ram-5.4.48+.patch b/fix-ck-broken-sleep2ram-5.4.48+.patch
new file mode 100644
index 000000000000..b43e9db1a568
--- /dev/null
+++ b/fix-ck-broken-sleep2ram-5.4.48+.patch
@@ -0,0 +1,31 @@
+From fb7e2cfaf61cf5f9c2336331e73296f455bd2d51 Mon Sep 17 00:00:00 2001
+From: Steven Barrett <steven@liquorix.net>
+Date: Sat, 27 Jun 2020 17:32:41 -0500
+Subject: [PATCH] muqss: Revert invocation of "finish_cpu" when offlining core
+
+Backporting the equivalent change in sched/core.c to sched/MuQSS.c in
+function, idle_task_exit, causes an oops at boot with MuQSS.
+
+Instead, make an exception for MuQSS so "finish_cpu" is not executed
+while running MuQSS and retain the original "idle_task_exit"
+implementation.
+---
+ kernel/cpu.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/kernel/cpu.c b/kernel/cpu.c
+index 244d305443773..90b77028233b0 100644
+--- a/kernel/cpu.c
++++ b/kernel/cpu.c
+@@ -1565,7 +1565,11 @@ static struct cpuhp_step cpuhp_hp_states[] = {
+ [CPUHP_BRINGUP_CPU] = {
+ .name = "cpu:bringup",
+ .startup.single = bringup_cpu,
++#ifdef CONFIG_SCHED_MUQSS
++ .teardown.single = NULL,
++#else
+ .teardown.single = finish_cpu,
++#endif
+ .cant_stop = true,
+ },
+ /* Final state before CPU kills itself */