summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD72
3 files changed, 63 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6aed097d5b5c..85e0446b1ea7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,31 @@
pkgbase = linux-show-player-git
- pkgdesc = Sound cue playback software designed for live musical shows and theatre plays (git version)
- pkgver = 0.5.1.r267.88156278
+ pkgdesc = Cue player designed for stage productions (git version)
+ pkgver = 0.6.0.dev0.r641.6fae70f7
pkgrel = 1
- url = http://linux-show-player.sourceforge.net/
+ url = https://www.linux-show-player.org/
arch = any
license = GPL3
makedepends = git
- makedepends = python-setuptools
- depends = python-pyqt5
- depends = python-gobject
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry
+ makedepends = python-wheel
depends = gst-plugins-good
+ depends = python-appdirs
+ depends = python-falcon
+ depends = python-gobject
+ depends = python-humanize
depends = python-mido
+ depends = python-pyalsa
+ depends = python-pyliblo
+ depends = python-pyqt5
+ depends = python-requests
+ depends = python-rtmidi
depends = python-sortedcontainers
depends = qt5-svg
optdepends = gst-libav: for larger format support
- optdepends = portmidi: for portmidi support
+ optdepends = ola: for Art-Net timecode support
+ optdepends = python-protobuf: for Art-Net timecode support
optdepends = python-jack-client: for JACK output support
provides = linux-show-player
conflicts = linux-show-player
@@ -23,4 +34,3 @@ pkgbase = linux-show-player-git
sha256sums = SKIP
pkgname = linux-show-player-git
-
diff --git a/.gitignore b/.gitignore
index 426addfe321d..7ef10f023519 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@ src/
.AURINFO
linux-show-player/
linux-show-player-*.tar.xz
+linux-show-player-*.tar.zst
linux-show-player-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 3d6018ea596e..81b7ed8e427e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,60 @@
# Maintainer: Christopher Arndt <chris at chrisarndt.de>
_pkgname=linux-show-player
-pkgname="${_pkgname}-git"
-pkgver=0.5.1.r267.88156278
+pkgname=$_pkgname-git
+pkgver=0.6.0.dev0.r641.6fae70f7
pkgrel=1
-pkgdesc="Sound cue playback software designed for live musical shows and theatre plays (git version)"
-url="http://linux-show-player.sourceforge.net/"
-arch=('any')
-license=('GPL3')
-depends=('python-pyqt5' 'python-gobject' 'gst-plugins-good' 'python-mido'
- 'python-sortedcontainers' 'qt5-svg')
-makedepends=('git' 'python-setuptools')
-optdepends=('gst-libav: for larger format support'
- 'portmidi: for portmidi support'
- 'python-jack-client: for JACK output support')
+pkgdesc='Cue player designed for stage productions (git version)'
+url='https://www.linux-show-player.org/'
+arch=(any)
+license=(GPL3)
+depends=(
+ gst-plugins-good
+ python-appdirs
+ python-falcon
+ python-gobject
+ python-humanize
+ python-mido
+ python-pyalsa
+ python-pyliblo
+ python-pyqt5
+ python-requests
+ python-rtmidi
+ python-sortedcontainers
+ qt5-svg
+)
+makedepends=(git python-build python-installer python-poetry python-wheel)
+optdepends=(
+ 'gst-libav: for larger format support'
+ 'ola: for Art-Net timecode support'
+ 'python-protobuf: for Art-Net timecode support'
+ 'python-jack-client: for JACK output support'
+)
options=('!emptydirs')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/FrancescoCeruti/linux-show-player")
+conflicts=($_pkgname)
+provides=($_pkgname)
+source=("$_pkgname::git+https://github.com/FrancescoCeruti/linux-show-player")
sha256sums=('SKIP')
-
pkgver() {
- cd "${srcdir}/${_pkgname}"
-
- ver=$(python -c "exec(open('lisp/__init__.py').read()); print(__version__)")
+ cd $_pkgname
+ grep '^__version' lisp/__init__.py > version.py
+ local ver=$(python -c "exec(open('version.py').read()); print(__version__)")
echo $ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
build() {
- cd "${srcdir}/${_pkgname}"
-
- python setup.py build
+ cd $_pkgname
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pkgname}"
-
- python setup.py install --root="${pkgdir}/" --prefix=/usr --optimize=1 --skip-build
- install -Dm644 dist/linuxshowplayer.desktop -t "${pkgdir}/usr/share/applications"
- install -Dm644 dist/linuxshowplayer.png -t "${pkgdir}/usr/share/pixmaps"
- install -Dm644 dist/linuxshowplayer.xml -t "${pkgdir}/usr/share/mime/packages"
+ cd $_pkgname
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 dist/linuxshowplayer.desktop \
+ -t "$pkgdir"/usr/share/applications
+ install -Dm644 dist/linuxshowplayer.png \
+ -t "$pkgdir"/usr/share/pixmaps
+ install -Dm644 dist/linuxshowplayer.xml \
+ -t "$pkgdir"/usr/share/mime/packages
}