summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5803aeb7a96d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = linux-timemachine-git
+ pkgdesc = Rsync-based OSX-like time machine for atomic and resumable local and remote backups
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/cytopia/linux-timemachine
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = rsync
+ optdepends = openssh: backup to remote (SCP) locations
+ source = linux-timemachine-git-1.0::git+https://github.com/cytopia/linux-timemachine.git
+ sha256sums = SKIP
+
+pkgname = linux-timemachine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f15fc3bb2bda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+
+pkgname="linux-timemachine-git"
+pkgdesc="Rsync-based OSX-like time machine for atomic and resumable local and remote backups"
+url="https://github.com/cytopia/linux-timemachine"
+
+pkgver=1.0
+pkgrel=0
+
+arch=("any")
+license=("MIT")
+
+makedepends=(
+ "git"
+)
+depends=(
+ "rsync"
+)
+optdepends=(
+ "openssh: backup to remote (SCP) locations"
+)
+
+source=(
+ "${pkgname}-${pkgver}::git+https://github.com/cytopia/linux-timemachine.git"
+)
+sha256sums=(
+ "SKIP"
+)
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ install \
+ -Dm755 \
+ timemachine \
+ "${pkgdir}/usr/bin/timemachine"
+
+ install \
+ -Dm644 \
+ LICENSE.md \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}