summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD29
2 files changed, 9 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82ca35aca2dd..4c1a05e6d703 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = linux-user-chroot
pkgdesc = setuid helper for making bind mounts and chrooting
pkgver = 2013.1
- pkgrel = 1
+ pkgrel = 2
url = http://git.gnome.org/browse/linux-user-chroot/tree/README
arch = i686
arch = x86_64
license = GPL
- makedepends = libxslt
makedepends = git
depends = glibc
+ source = https://git.gnome.org/browse/linux-user-chroot/snapshot/linux-user-chroot-2013.1.tar.gz
+ sha1sums = 4d158e691732ad6e6be95203146c448bd64e90a0
pkgname = linux-user-chroot
diff --git a/PKGBUILD b/PKGBUILD
index aa29c4a7d7d0..d935e516c5ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,23 @@
pkgname='linux-user-chroot'
pkgver='2013.1'
-pkgrel='1'
+pkgrel='2'
pkgdesc='setuid helper for making bind mounts and chrooting'
url='http://git.gnome.org/browse/linux-user-chroot/tree/README'
arch=('i686' 'x86_64')
license='GPL'
depends=('glibc')
-makedepends=('libxslt' 'git')
-repo="git://git.gnome.org/${pkgname}"
+makedepends=('git')
+source=("https://git.gnome.org/browse/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('4d158e691732ad6e6be95203146c448bd64e90a0')
build () {
- cd "${srcdir}"
-
- msg "Connecting to the ${pkgname} Git repository..."
- if [ -d "${srcdir}/${pkgname}" ] ; then
- cd "${pkgname}" && git fetch origin
- msg "The local files are updated."
- else
- git clone "${repo}" "${pkgname}"
- fi
- cd "${srcdir}/${pkgname}"
-
- msg2 "Checking out version v${pkgver}"
- git checkout --force "v${pkgver}"
- msg "GIT checkout done or server timeout"
-
- msg2 "Configuring..."
+ cd "${srcdir}/${pkgname}-${pkgver}"
./autogen.sh --prefix=/usr --enable-newnet-helper
- msg2 "Compiling..."
make
}
package() {
- cd "${srcdir}/${pkgname}"
-
- msg2 "Packaging..."
+ cd "${srcdir}/${pkgname}-${pkgver}"
make install DESTDIR="${pkgdir}"
chmod +s "${pkgdir}/usr/bin"/linux-user-chroot{,-newnet}
}