aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--add-acs-overrides.patch19
-rw-r--r--i915-vga-arbiter.patch17
4 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57ff323fd0a8..8a559af2fcc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,8 +29,8 @@ pkgbase = linux-vfio
validpgpkeys = A2FF3A36AAA56654109064AB19802F8B0D70FC30
sha256sums = SKIP
sha256sums = d3e7adf5fcfc632887058ca84ca7b849a824dda5a03de854c8d3480ef0124ad1
- sha256sums = d3723da5cff1dce0a29bb704264dacccab559373a00fbbe97b12745dcf144b3d
- sha256sums = 167dbad8da63a70df243273b8a246357215f832406063d2637d87a1ae2b6f1bb
+ sha256sums = b90be7b79652be61f7d50691000f6a8c75a240dc2eee2667b68d984f67583f77
+ sha256sums = 1c621f67bbf9efef610d1b2d1afd727fca9ceaa298f807bd0348b59ec6ce9562
pkgname = linux-vfio
pkgdesc = The Linux kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index ae001b96d378..e4935052b0c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,8 +31,8 @@ validpgpkeys=(
)
sha256sums=('SKIP'
'd3e7adf5fcfc632887058ca84ca7b849a824dda5a03de854c8d3480ef0124ad1'
- 'd3723da5cff1dce0a29bb704264dacccab559373a00fbbe97b12745dcf144b3d'
- '167dbad8da63a70df243273b8a246357215f832406063d2637d87a1ae2b6f1bb')
+ 'b90be7b79652be61f7d50691000f6a8c75a240dc2eee2667b68d984f67583f77'
+ '1c621f67bbf9efef610d1b2d1afd727fca9ceaa298f807bd0348b59ec6ce9562')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
diff --git a/add-acs-overrides.patch b/add-acs-overrides.patch
index 9dee450f2ce0..f291975edb48 100644
--- a/add-acs-overrides.patch
+++ b/add-acs-overrides.patch
@@ -1,7 +1,7 @@
-From 169ce1a1bf376ba90cd0ab51ec19f9e32ead9dcb Mon Sep 17 00:00:00 2001
+From 578d958c59002358abdeeb294c25ac28027b9f7a Mon Sep 17 00:00:00 2001
From: Mark Weiman <mark.weiman@markzz.com>
-Date: Wed, 6 May 2020 15:40:50 -0400
-Subject: [PATCH] pci: Enable overrides for missing ACS capabilities (5.6.9+)
+Date: Wed, 27 Jan 2021 13:28:09 -0500
+Subject: [PATCH] pci: Enable overrides for missing ACS capabilities (5.10.11+)
This an updated version of Alex Williamson's patch from:
https://lkml.org/lkml/2013/5/30/513
@@ -42,12 +42,14 @@ are available. It's suggested to use the most limited set of options
necessary to avoid completely disabling ACS across the topology.
Note to hardware vendors, we have facilities to permanently quirk
specific devices which enforce isolation but not provide an ACS
-capability. Please contact me to have your devices added and save
-your customers the hassle of this boot option.
+capability. Please contact me to have your devicstarting
---
+ .../admin-guide/kernel-parameters.txt | 8 ++
+ drivers/pci/quirks.c | 102 ++++++++++++++++++
+ 2 files changed, 110 insertions(+)
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
-index f6a1513dfb76..3c3e25cdc90e 100644
+index 26bfe7ae711b..7babcf646686 100644
--- a/Documentation/admin-guide/kernel-parameters.txt
+++ b/Documentation/admin-guide/kernel-parameters.txt
@@ -3629,6 +3629,14 @@
@@ -66,7 +68,7 @@ index f6a1513dfb76..3c3e25cdc90e 100644
Safety option to keep boot IRQs enabled. This
should never be necessary.
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
-index f70692ac79c5..e1208a614703 100644
+index fb1dc11e7cc5..8748df0fe1e1 100644
--- a/drivers/pci/quirks.c
+++ b/drivers/pci/quirks.c
@@ -192,6 +192,106 @@ static int __init pci_apply_final_quirks(void)
@@ -185,3 +187,6 @@ index f70692ac79c5..e1208a614703 100644
{ 0 }
};
+--
+2.30.0
+
diff --git a/i915-vga-arbiter.patch b/i915-vga-arbiter.patch
index 0393762136f1..d34103128728 100644
--- a/i915-vga-arbiter.patch
+++ b/i915-vga-arbiter.patch
@@ -1,11 +1,12 @@
-From 48be7e32f897277d77359e37db452281dd8b3bf8 Mon Sep 17 00:00:00 2001
+From a59b6ecac96eab5e80fa5ee918ddbc8e2fad3a7a Mon Sep 17 00:00:00 2001
From: Mark Weiman <mark.weiman@markzz.com>
-Date: Tue, 8 Oct 2019 18:48:25 -0400
+Date: Wed, 27 Jan 2021 13:28:46 -0500
Subject: [PATCH] i915: Add module option to support VGA arbiter on HD devices
- (5.3)
+ (5.10)
This is an updated version of Alex Williamson's patch from:
https://lkml.org/lkml/2014/5/9/517
+
I don't have i915 graphics, so this is completely untested.
Original commit message follows:
@@ -35,6 +36,13 @@ This also rolls in reverted commit 6e1b4fda, which corrected an
ordering issue with 81b5c7bc by delaying the disabling of VGA memory
until after vgacon->fbcon handoff.
---
+ drivers/gpu/drm/i915/display/intel_display.c | 15 +++++++--
+ drivers/gpu/drm/i915/display/intel_display.h | 1 +
+ drivers/gpu/drm/i915/display/intel_vga.c | 32 ++++++++++++++++++++
+ drivers/gpu/drm/i915/display/intel_vga.h | 4 +++
+ drivers/gpu/drm/i915/i915_params.c | 3 ++
+ drivers/gpu/drm/i915/i915_params.h | 1 +
+ 6 files changed, 53 insertions(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/i915/display/intel_display.c b/drivers/gpu/drm/i915/display/intel_display.c
index aabf09f89cad..528c6886a0b5 100644
@@ -177,3 +185,6 @@ index 330c03e2b4f7..b44a4b7dba4d 100644
param(bool, enable_hangcheck, true, 0600) \
param(bool, load_detect_test, false, 0600) \
param(bool, force_reset_modeset_test, false, 0600) \
+--
+2.30.0
+