summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD23
-rw-r--r--linux-wifi-hotspot.install24
2 files changed, 20 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa5a8cdbc45b..f55673b50bdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
-# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=linux-wifi-hotspot
pkgver=3.6.7
pkgrel=1
@@ -7,12 +7,7 @@ pkgdesc="Create virtual wifi hotspot using same wifi card which is connected to
arch=('x86_64')
url="https://github.com/lakinduakash/linux-wifi-hotspot"
license=('BSD')
-depends=('hostapd'
- 'iw'
- 'gtk3'
- 'procps-ng'
- 'dnsmasq'
- 'iproute2')
+depends=('hostapd' 'iw' 'gtk3' 'procps-ng' 'dnsmasq' 'iproute2')
optdepends=('haveged: For random MAC generation'
'wireless_tools: if iw cannot recognize your adapter'
'bash-completion: for bash completions')
@@ -24,15 +19,13 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('ae910e5982cb390cb63f828f48f8137af91e03ff2a6ca2db2ca4383b62a2376c')
build() {
- cd "${pkgname}-${pkgver}"
- make
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/linux-wifi-hotspot.install b/linux-wifi-hotspot.install
index 5502bfb47169..2315a69693ac 100644
--- a/linux-wifi-hotspot.install
+++ b/linux-wifi-hotspot.install
@@ -1,21 +1,21 @@
post_install() {
- echo ""
- echo "Start the hotspot service on startup (using your saved configuration) with:"
- echo "systemctl enable --now create_ap"
- echo ""
+ echo ""
+ echo "Start the hotspot service on startup (using your saved configuration) with:"
+ echo "systemctl enable --now create_ap"
+ echo ""
}
post_upgrade() {
- # Remove old file from previous versions if existing
- if [ -f /etc/sudoers.d/create_ap ]; then
- rm /etc/sudoers.d/create_ap
- fi
+ # Remove old file from previous versions if existing
+ if [ -f /etc/sudoers.d/create_ap ]; then
+ rm /etc/sudoers.d/create_ap
+ fi
}
post_remove() {
- echo ""
- echo "Optionally remove config file:"
- echo "sudo rm /etc/wh.config"
- echo ""
+ echo ""
+ echo "Optionally remove config file:"
+ echo "sudo rm /etc/wh.config"
+ echo ""
}