summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD7
-rw-r--r--config5
-rw-r--r--sphinx-workaround.patch19
4 files changed, 9 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3bdb286c325..ccdb81a8cca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = linux-x32
pkgdesc = Linux with x32 ABI
- pkgver = 5.11.2.arch1
+ pkgver = 5.11.4.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v5.11.2-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v5.11.4-arch1
arch = x86_64
license = GPL2
makedepends = bc
@@ -20,15 +20,13 @@ pkgbase = linux-x32
makedepends = imagemagick
makedepends = git
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.11.2-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.11.4-arch1
source = config
- source = sphinx-workaround.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = A2FF3A36AAA56654109064AB19802F8B0D70FC30
sha256sums = SKIP
- sha256sums = fcb803d48f10925b94b59ffb90f6e1612ca7e46bdd1b65a094229ebd02ecb537
- sha256sums = 52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb
+ sha256sums = 994bec2de3b5ad11d07b5e099e55ea95aaa42ae0993107bd02f21da2c30a7ff7
pkgname = linux-x32
pkgdesc = The Linux with x32 ABI kernel and modules
@@ -39,8 +37,6 @@ pkgname = linux-x32
optdepends = linux-firmware: firmware images needed for some devices
provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
- replaces = virtualbox-guest-modules-arch
- replaces = wireguard-arch
pkgname = linux-x32-headers
pkgdesc = Headers and scripts for building modules for the Linux with x32 ABI kernel
diff --git a/PKGBUILD b/PKGBUILD
index 7c26d6a2ce43..49ed7aa7aa4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer (core/linux): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-x32
-pkgver=5.11.2.arch1
+pkgver=5.11.4.arch1
pkgrel=1
pkgdesc='Linux with x32 ABI'
_srctag=v${pkgver%.*}-${pkgver##*.}
@@ -19,7 +19,6 @@ _srcname=archlinux-linux
source=(
"$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=$_srctag"
config # the main kernel config file
- sphinx-workaround.patch # Sphinx 3.5 broke the build again
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -27,8 +26,7 @@ validpgpkeys=(
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'fcb803d48f10925b94b59ffb90f6e1612ca7e46bdd1b65a094229ebd02ecb537'
- '52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb')
+ '994bec2de3b5ad11d07b5e099e55ea95aaa42ae0993107bd02f21da2c30a7ff7')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -71,7 +69,6 @@ _package() {
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
- replaces=(virtualbox-guest-modules-arch wireguard-arch)
cd $_srcname
local kernver="$(<version)"
diff --git a/config b/config
index fb92e5d84f4b..1576459ed078 100644
--- a/config
+++ b/config
@@ -1,11 +1,11 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.11.0-arch1 Kernel Configuration
+# Linux/x86 5.11.4-arch1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 10.2.0"
CONFIG_CC_IS_GCC=y
CONFIG_GCC_VERSION=100200
-CONFIG_LD_VERSION=236000000
+CONFIG_LD_VERSION=236010000
CONFIG_CLANG_VERSION=0
CONFIG_LLD_VERSION=0
CONFIG_CC_CAN_LINK=y
@@ -262,6 +262,7 @@ CONFIG_BPF_PRELOAD=y
CONFIG_BPF_PRELOAD_UMD=m
CONFIG_USERFAULTFD=y
CONFIG_ARCH_HAS_MEMBARRIER_SYNC_CORE=y
+CONFIG_KCMP=y
CONFIG_RSEQ=y
# CONFIG_EMBEDDED is not set
CONFIG_HAVE_PERF_EVENTS=y
diff --git a/sphinx-workaround.patch b/sphinx-workaround.patch
deleted file mode 100644
index a6e2c4900290..000000000000
--- a/sphinx-workaround.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git i/Documentation/conf.py w/Documentation/conf.py
-index 6a767294887e..d1d145759fed 100644
---- i/Documentation/conf.py
-+++ w/Documentation/conf.py
-@@ -267,11 +267,9 @@ except ImportError:
-
- html_static_path = ['sphinx-static']
-
--html_context = {
-- 'css_files': [
-- '_static/theme_overrides.css',
-- ],
--}
-+html_css_files = [
-+ '_static/theme_overrides.css',
-+]
-
- # Add any extra paths that contain custom files (such as robots.txt or
- # .htaccess) here, relative to this directory. These files are copied