summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD11
-rw-r--r--config5
4 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a04612163681..c77f0ceb2cb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-x32
- pkgver = 4.19.2.arch1
+ pkgver = 4.19.4.arch1
pkgrel = 1
- url = https://git.archlinux.org/linux.git/log/?h=v4.19.2-arch1
+ url = https://git.archlinux.org/linux.git/log/?h=v4.19.4-arch1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -13,7 +13,7 @@ pkgbase = linux-x32
makedepends = python-sphinx
makedepends = graphviz
options = !strip
- source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.19.2-arch1
+ source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v4.19.4-arch1
source = config
source = 60-linux.hook
source = 90-linux.hook
@@ -22,7 +22,7 @@ pkgbase = linux-x32
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = 8218F88849AAC522E94CF470A5E9288C4FA415FA
sha256sums = SKIP
- sha256sums = ce0ebaba9614895e681195cec833acabe75f66330611ff0b01bc8f8cce2c01b1
+ sha256sums = 0432c94268beab9d4279cd73b7a99888cbc84c14a7f569b8e62f446e05c7ac7b
sha256sums = ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21
sha256sums = 75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919
sha256sums = ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1752dee861cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+linux-x32-*.pkg.tar.xz
+linux.install.pkg
+archlinux-linux/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 362bcacbb1cc..095e6c43d321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-x32
-_srcver=4.19.2-arch1
+_srcver=4.19.4-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -26,7 +26,7 @@ validpgpkeys=(
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'ce0ebaba9614895e681195cec833acabe75f66330611ff0b01bc8f8cce2c01b1'
+ '0432c94268beab9d4279cd73b7a99888cbc84c14a7f569b8e62f446e05c7ac7b'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -77,13 +77,18 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
diff --git a/config b/config
index 9dec46439c61..855a3ca0db8f 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.2-arch1 Kernel Configuration
+# Linux/x86 4.19.3-arch1 Kernel Configuration
#
#
@@ -1603,6 +1603,7 @@ CONFIG_L2TP_V3=y
CONFIG_L2TP_IP=m
CONFIG_L2TP_ETH=m
CONFIG_STP=m
+CONFIG_GARP=m
CONFIG_MRP=m
CONFIG_BRIDGE=m
CONFIG_BRIDGE_IGMP_SNOOPING=y
@@ -1619,7 +1620,7 @@ CONFIG_NET_DSA_TAG_LAN9303=y
CONFIG_NET_DSA_TAG_MTK=y
CONFIG_NET_DSA_TAG_QCA=y
CONFIG_VLAN_8021Q=m
-# CONFIG_VLAN_8021Q_GVRP is not set
+CONFIG_VLAN_8021Q_GVRP=y
CONFIG_VLAN_8021Q_MVRP=y
# CONFIG_DECNET is not set
CONFIG_LLC=m