summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1451c2e0e23..c5d5268a9703 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-xanmod-anbox
pkgdesc = Linux Xanmod with ashmem and binder enabled for Anbox
pkgver = 5.13.0
- pkgrel = 1
+ pkgrel = 3
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
@@ -14,16 +14,14 @@ pkgbase = linux-xanmod-anbox
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.13.0-xanmod1/patch-5.13.0-xanmod1.xz
+ source = https://github.com/xanmod/linux/releases/download/5.13.0-xanmod2/patch-5.13.0-xanmod2.xz
source = choose-gcc-optimization.sh
- source = sphinx-workaround.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/sphinx-workaround.patch?h=packages/linux&id=be7d4710850020de55bce930c83fa80347c02fc3
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 3f6baa97f37518439f51df2e4f3d65a822ca5ff016aa8e60d2cc53b95a6c89d9
sha256sums = SKIP
- sha256sums = e829aa290b5f00812d9f496e4e3397621f9184e0c07db05d328ba83e69d1b34f
+ sha256sums = 42cb550e7b9900820bdc9f528eb60c726f19294417065bf3a0b94be06388aeb1
sha256sums = 1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee
- sha256sums = 52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb
pkgname = linux-xanmod-anbox
pkgdesc = The Linux kernel and modules with Xanmod patches and ashmem and binder enabled
diff --git a/PKGBUILD b/PKGBUILD
index 6e1a3dd57fcf..e9c230ea9e5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
##
## The following variables can be customized at build time. Use env or export to change at your wish
##
-## Example: env _microarchitecture=99 use_numa=n use_tracers=n use_pds=n makepkg -sc
+## Example: env _microarchitecture=98 use_numa=n use_tracers=n makepkg -sc
##
## Look inside 'choose-gcc-optimization.sh' to choose your microarchitecture
## Valid numbers between: 0 to 99
@@ -60,8 +60,8 @@ pkgbase=linux-xanmod-anbox
_major=5.13
pkgver=${_major}.0
_branch=5.x
-xanmod=1
-pkgrel=${xanmod}
+xanmod=2
+pkgrel=3
pkgdesc='Linux Xanmod with ashmem and binder enabled for Anbox'
url="http://www.xanmod.org/"
arch=(x86_64)
@@ -86,17 +86,17 @@ validpgpkeys=(
)
# Archlinux patches
-_commit="be7d4710850020de55bce930c83fa80347c02fc3"
-_patches=("sphinx-workaround.patch")
+_commit="ec9e9a4219fe221dec93fa16fddbe44a34933d8d"
+_patches=()
for _patch in ${_patches[@]}; do
- source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
+ #source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
+ source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
sha256sums=('3f6baa97f37518439f51df2e4f3d65a822ca5ff016aa8e60d2cc53b95a6c89d9'
'SKIP'
- 'e829aa290b5f00812d9f496e4e3397621f9184e0c07db05d328ba83e69d1b34f'
- '1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee'
- '52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb')
+ '42cb550e7b9900820bdc9f528eb60c726f19294417065bf3a0b94be06388aeb1'
+ '1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}