summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xchoose-gcc-optimization.sh7
3 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ff7f4ad70c1..dc2d24441f91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-anbox
pkgdesc = Linux Xanmod with ashmem and binder enabled for Anbox
- pkgver = 5.12.5
+ pkgver = 5.12.6
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -14,15 +14,15 @@ pkgbase = linux-xanmod-anbox
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.12.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.12.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.12.5-xanmod1/patch-5.12.5-xanmod1.xz
+ source = https://github.com/xanmod/linux/releases/download/5.12.6-xanmod1/patch-5.12.6-xanmod1.xz
source = choose-gcc-optimization.sh
source = sphinx-workaround.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/sphinx-workaround.patch?h=packages/linux&id=be7d4710850020de55bce930c83fa80347c02fc3
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 7d0df6f2bf2384d68d0bd8e1fe3e071d64364dcdc6002e7b5c87c92d48fac366
sha256sums = SKIP
- sha256sums = dd84cb043350cc29a029ac86442e50e7a60a55623ddf8b3450fbd078eeb295a9
- sha256sums = 51742dee57cd15bece152d6527f48af87cb7930f0f6a356d5282f778e7c35b39
+ sha256sums = 2bb72c4ac95cfd63abd2890d23fc12a946874114ca1c48c5a75143866821953c
+ sha256sums = 1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee
sha256sums = 52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb
pkgname = linux-xanmod-anbox
diff --git a/PKGBUILD b/PKGBUILD
index 043c678ef163..fdf37d8717f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,7 +53,7 @@ _makenconfig=
pkgbase=linux-xanmod-anbox
_major=5.12
-pkgver=${_major}.5
+pkgver=${_major}.6
_branch=5.x
xanmod=1
pkgrel=${xanmod}
@@ -86,8 +86,8 @@ done
sha256sums=('7d0df6f2bf2384d68d0bd8e1fe3e071d64364dcdc6002e7b5c87c92d48fac366'
'SKIP'
- 'dd84cb043350cc29a029ac86442e50e7a60a55623ddf8b3450fbd078eeb295a9'
- '51742dee57cd15bece152d6527f48af87cb7930f0f6a356d5282f778e7c35b39'
+ '2bb72c4ac95cfd63abd2890d23fc12a946874114ca1c48c5a75143866821953c'
+ '1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee'
'52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
diff --git a/choose-gcc-optimization.sh b/choose-gcc-optimization.sh
index e45a21084594..f10eec54b81d 100755
--- a/choose-gcc-optimization.sh
+++ b/choose-gcc-optimization.sh
@@ -59,6 +59,10 @@ cat << EOF
46) Intel Rocket Lake
47) Intel Alder Lake
+ 92) Generic-x86-64-v2 (Nehalem and newer)
+ 93) Generic-x86-64-v3 (Haswell and newer)
+ 94) Generic-x86-64-v4 (AVX512 CPUs)
+
98) Intel-Native optimizations autodetected by GCC
99) AMD-Native optimizations autodetected by GCC
@@ -117,6 +121,9 @@ case $answer in
45) Microarchitecture=CONFIG_MSAPPHIRERAPIDS ;;
46) Microarchitecture=CONFIG_MROCKETLAKE ;;
47) Microarchitecture=CONFIG_MALDERLAKE ;;
+ 92) Microarchitecture=CONFIG_GENERIC_CPU2 ;;
+ 93) Microarchitecture=CONFIG_GENERIC_CPU3 ;;
+ 94) Microarchitecture=CONFIG_GENERIC_CPU4 ;;
98) Microarchitecture=CONFIG_MNATIVE_INTEL ;;
99) Microarchitecture=CONFIG_MNATIVE_AMD ;;
*) default=CONFIG_GENERIC_CPU ;;