summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7336be19191e..21b14b35f84b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-anbox
pkgdesc = Linux Xanmod with ashmem and binder enabled for Anbox - Current Stable (STABLE)
- pkgver = 5.13.19
+ pkgver = 5.14.9
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -13,15 +13,15 @@ pkgbase = linux-xanmod-anbox
makedepends = tar
makedepends = xz
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.xz
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.13.19-xanmod1/patch-5.13.19-xanmod1.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.14.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.14.tar.sign
+ source = https://github.com/xanmod/linux/releases/download/5.14.9-xanmod1/patch-5.14.9-xanmod1.xz
source = choose-gcc-optimization.sh
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 3f6baa97f37518439f51df2e4f3d65a822ca5ff016aa8e60d2cc53b95a6c89d9
+ sha256sums = 7e068b5e0d26a62b10e5320b25dce57588cbbc6f781c090442138c9c9c3271b2
sha256sums = SKIP
- sha256sums = ba173136348108df3066db4c2e2c0539e16162fa017aa738df81de85e0124657
+ sha256sums = 6411c502e290ed9b77fc314a885cc8ca23f0674e821afa04ae263482e9cbb076
sha256sums = 1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee
pkgname = linux-xanmod-anbox
diff --git a/PKGBUILD b/PKGBUILD
index 74b30fcc4417..3cc45eeedbfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,6 +39,11 @@ if [ -z ${_compiler+x} ]; then
_compiler=gcc
fi
+# Compress modules with ZSTD (to save disk space)
+if [ -z ${_compress_modules+x} ]; then
+ _compress_modules=n
+fi
+
# Compile ONLY used modules to VASTLY reduce the number of modules built
# and the build time.
#
@@ -57,8 +62,8 @@ _makenconfig=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-anbox
-_major=5.13
-pkgver=${_major}.19
+_major=5.14
+pkgver=${_major}.9
_branch=5.x
xanmod=1
pkgrel=${xanmod}
@@ -93,9 +98,9 @@ for _patch in ${_patches[@]}; do
source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
-sha256sums=('3f6baa97f37518439f51df2e4f3d65a822ca5ff016aa8e60d2cc53b95a6c89d9'
+sha256sums=('7e068b5e0d26a62b10e5320b25dce57588cbbc6f781c090442138c9c9c3271b2'
'SKIP'
- 'ba173136348108df3066db4c2e2c0539e16162fa017aa738df81de85e0124657'
+ '6411c502e290ed9b77fc314a885cc8ca23f0674e821afa04ae263482e9cbb076'
'1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -161,6 +166,11 @@ prepare() {
scripts/config --disable CONFIG_NUMA
fi
+ # Compress modules by default (following Arch's kernel)
+ if [ "$_compress_modules" = "y" ]; then
+ scripts/config --enable CONFIG_MODULE_COMPRESS_ZSTD
+ fi
+
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture