summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rwxr-xr-xchoose-gcc-optimization.sh8
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5642680cbb27..4e93ca0a2f5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-anbox
pkgdesc = Linux Xanmod with ashmem and binder enabled for Anbox
- pkgver = 5.10.11
+ pkgver = 5.10.12
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -14,15 +14,15 @@ pkgbase = linux-xanmod-anbox
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.10.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.10.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.10.11-xanmod1/patch-5.10.11-xanmod1.xz
+ source = https://github.com/xanmod/linux/releases/download/5.10.12-xanmod1/patch-5.10.12-xanmod1.xz
source = choose-gcc-optimization.sh
source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43
sha256sums = SKIP
- sha256sums = d881e96f0480ce51ca343c1ced9fd4543e15f07d06b9bff400df4fafb2512de0
- sha256sums = 2c7369218e81dee86f8ac15bda741b9bb34fa9cefcb087760242277a8207d511
+ sha256sums = 0adfa0d4ffd57a8c1da67a42f8b0d1bdb7f7454419fbfe5e5387a07209d3e0be
+ sha256sums = 03bb8b234a67b877a34a8212936ba69d8700c54c7877686cbd9742a536c87134
sha256sums = 6c66dba73251440352f93ff32b72f5dd49536d0f17ef9347867660fd3a626991
pkgname = linux-xanmod-anbox
diff --git a/PKGBUILD b/PKGBUILD
index a1393058dc01..35ca8a2852e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@
##
## The following variables can be customized at build time. Use env or export to change at your wish
##
-## Example: env _microarchitecture=25 use_numa=n use_tracers=n use_pds=n makepkg -sc
+## Example: env _microarchitecture=99 use_numa=n use_tracers=n use_pds=n makepkg -sc
##
## Look inside 'choose-gcc-optimization.sh' to choose your microarchitecture
-## Valid numbers between: 0 to 42
+## Valid numbers between: 0 to 99
## Default is: 0 => generic
-## Good option if your package is for one machine: 42 => native
+## Good option if your package is for one machine: 99 => native
if [ -z ${_microarchitecture+x} ]; then
_microarchitecture=0
fi
@@ -66,7 +66,7 @@ _makenconfig=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-anbox
-pkgver=5.10.11
+pkgver=5.10.12
_major=5.10
_branch=5.x
xanmod=1
@@ -99,8 +99,8 @@ done
sha256sums=('dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43'
'SKIP'
- 'd881e96f0480ce51ca343c1ced9fd4543e15f07d06b9bff400df4fafb2512de0'
- '2c7369218e81dee86f8ac15bda741b9bb34fa9cefcb087760242277a8207d511'
+ '0adfa0d4ffd57a8c1da67a42f8b0d1bdb7f7454419fbfe5e5387a07209d3e0be'
+ '03bb8b234a67b877a34a8212936ba69d8700c54c7877686cbd9742a536c87134'
'6c66dba73251440352f93ff32b72f5dd49536d0f17ef9347867660fd3a626991')
# If use_cachy=y then download cachy patch
diff --git a/choose-gcc-optimization.sh b/choose-gcc-optimization.sh
index ccf182e91190..1a537df29334 100755
--- a/choose-gcc-optimization.sh
+++ b/choose-gcc-optimization.sh
@@ -52,8 +52,10 @@ cat << EOF
39) Intel 8th Gen Core i3/i5/i7-family (Cannon Lake)
40) Intel 8th Gen Core i7/i9-family (Ice Lake)
41) Xeon processors in the Cascade Lake family
+ 42) Intel Xeon (Cooper Lake)
+ 43) Intel 3rd Gen 10nm++ i3/i5/i7/i9-family (Tiger Lake)
- 42) Native optimizations autodetected by GCC
+ 99) Native optimizations autodetected by GCC
0) Generic (default)
@@ -104,7 +106,9 @@ case $answer in
39) Microarchitecture=CONFIG_MCANNONLAKE ;;
40) Microarchitecture=CONFIG_MICELAKE ;;
41) Microarchitecture=CONFIG_MCASCADELAKE ;;
- 42) Microarchitecture=CONFIG_MNATIVE ;;
+ 42) Microarchitecture=CONFIG_MCOOPERLAKE ;;
+ 43) Microarchitecture=CONFIG_MTIGERLAKE ;;
+ 99) Microarchitecture=CONFIG_MNATIVE ;;
*) default=CONFIG_GENERIC_CPU ;;
esac