summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 272d5362bd1e..8ba85a599901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -162,6 +162,9 @@ prepare() {
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture
+ # Disable CONFIG_GENERIC_CPU2 if we have choosen another microarchitecture
+ # https://github.com/xanmod/linux/issues/240
+ [ "$_microarchitecture" = "0" ] || scripts/config --disable CONFIG_GENERIC_CPU2
# This is intended for the people that want to build this package with their own config
# Put the file "myconfig" at the package folder (this will take preference) or "${XDG_CONFIG_HOME}/linux-xanmod/myconfig"