aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD12
-rw-r--r--myconfig5
2 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c2f5522ec8e..8f73b74e8e7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -335,6 +335,18 @@ prepare() {
# NOTE: this script must run *after* make olddefconfig so any new uarch macros exist
sh "${srcdir}/choose-gcc-optimization.sh" $_microarchitecture
+ ## bake in s0ix debugging parameters
+ scripts/config --enable CONFIG_CMDLINE_BOOL \
+ --set-str CONFIG_CMDLINE "makepkgplaceholderyolo" \
+ --disable CMDLINE_OVERRIDE
+
+ ## HACK: forcibly fixup CONFIG_CMDLINE as scripts/config mangles quote escapes
+
+ # note the double escaped quotes here, sed strips one;
+ # the final result in .config needs to look like CONFIG_CMDLINE="foo.dyndbg=\"+p\"" to avoid dyndbg parse errors at boot
+
+ sed -i 's#makepkgplaceholderyolo#pm_debug_messages amd_pmc.enable_stb=1 amd_pmc.dyndbg=\\"+p\\" acpi.dyndbg=\\"file drivers/acpi/x86/s2idle.c +p\\"#' .config
+
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
diff --git a/myconfig b/myconfig
index f5246e8ffb68..170727843085 100644
--- a/myconfig
+++ b/myconfig
@@ -5,10 +5,7 @@
scripts/config --disable CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE
scripts/config --enable CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL
-## s0ix debugging
-scripts/config --enable CONFIG_CMDLINE_BOOL \
- --set-str CONFIG_CMDLINE "pm_debug_messages amd_pmc.dyndbg=+p \\'acpi.dyndbg=file drivers/acpi/x86/s2idle.c +p\\' amd_pmc.enable_stb=1" \
- --disable CMDLINE_OVERRIDE
+## s0ix debugging moved into PKGBUILD
## asusctl/supergfxctl compatibility
scripts/config --module CONFIG_VFIO_IOMMU_TYPE1 \