aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--myconfig6
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df042b663727..bf858e404dcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-rog
pkgdesc = Linux Xanmod
- pkgver = 5.14.14.xanpre0
+ pkgver = 5.14.14.xanmod2
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -18,10 +18,9 @@ pkgbase = linux-xanmod-rog
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.14.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.14.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.14.13-xanmod1/patch-5.14.13-xanmod1.xz
+ source = https://github.com/xanmod/linux/releases/download/5.14.14-xanmod2/patch-5.14.14-xanmod2.xz
source = choose-gcc-optimization.sh
source = sphinx-workaround.patch
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/incr/patch-5.14.13-14.xz
source = x86-ACPI-State-Optimize-C3-entry-on-AMD-CPUs.patch
source = acpi-battery-Always-read-fresh-battery-state-on-update.patch
source = hwmon-k10temp-support-Zen3-APUs.patch
@@ -56,10 +55,9 @@ pkgbase = linux-xanmod-rog
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 7e068b5e0d26a62b10e5320b25dce57588cbbc6f781c090442138c9c9c3271b2
sha256sums = SKIP
- sha256sums = df403c2e2725871dff62152551d5ba213beeb8a604571aa78c8d8885f4a0bf34
+ sha256sums = 4a2b8d9c450ad11bab0f67095071f32cce513d45684ac12cb9fc579fd0d86710
sha256sums = 1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee
sha256sums = 52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb
- sha256sums = 260ee04fc176684703e46d206b68367c102ee6ab846a627d02a10e5a066d1669
sha256sums = 923230ed8367e28adfdeed75d3cdba9eec6b781818c37f6f3d3eb64101d2e716
sha256sums = f7a4bf6293912bfc4a20743e58a5a266be8c4dbe3c1862d196d3a3b45f2f7c90
sha256sums = de8c9747637768c4356c06aa65c3f157c526aa420f21fdd5edd0ed06f720a62e
diff --git a/PKGBUILD b/PKGBUILD
index 9c3382452b6a..4c2f5522ec8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -80,9 +80,9 @@ _makenconfig=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-rog
-xanmod=5.14.13-xanmod1
-#pkgver=${xanmod//-/.}
-pkgver=5.14.14.xanpre0 # NOTE: start 4th position with 'xan...', we rely on parsing for '.xan...' later
+xanmod=5.14.14-xanmod2
+pkgver=${xanmod//-/.}
+#pkgver=5.14.14.xanpre0 # NOTE: start 4th position with 'xan...', we rely on parsing for '.xan...' later
pkgrel=1
pkgdesc='Linux Xanmod'
url="http://www.xanmod.org/"
@@ -108,7 +108,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
# incremental kernel.org patch ahead of official Xanmod release
#"https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.14.1.xz"
- "https://cdn.kernel.org/pub/linux/kernel/v5.x/incr/patch-5.14.13-14.xz"
+ #"https://cdn.kernel.org/pub/linux/kernel/v5.x/incr/patch-5.14.13-14.xz"
# stable rc patches
#"Linux-5.14.5-rc1.patch"
@@ -167,10 +167,9 @@ validpgpkeys=(
sha256sums=('7e068b5e0d26a62b10e5320b25dce57588cbbc6f781c090442138c9c9c3271b2'
'SKIP'
- 'df403c2e2725871dff62152551d5ba213beeb8a604571aa78c8d8885f4a0bf34'
+ '4a2b8d9c450ad11bab0f67095071f32cce513d45684ac12cb9fc579fd0d86710'
'1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee'
'52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb'
- '260ee04fc176684703e46d206b68367c102ee6ab846a627d02a10e5a066d1669'
'923230ed8367e28adfdeed75d3cdba9eec6b781818c37f6f3d3eb64101d2e716'
'f7a4bf6293912bfc4a20743e58a5a266be8c4dbe3c1862d196d3a3b45f2f7c90'
'de8c9747637768c4356c06aa65c3f157c526aa420f21fdd5edd0ed06f720a62e'
diff --git a/myconfig b/myconfig
index 950bb1848cae..f5246e8ffb68 100644
--- a/myconfig
+++ b/myconfig
@@ -115,5 +115,7 @@ scripts/config --module CONFIG_ACPI_APEI_ERST_DEBUG
# enable multigen LRU by default
scripts/config --enable CONFIG_LRU_GEN_ENABLED
-# AMD pstate
-scripts/config --enable CONFIG_X86_AMD_PSTATE
+## AMD pstate
+#scripts/config --module CONFIG_X86_AMD_PSTATE
+# NOTE: We'll ignore this for now, it's configured as a module in Xanmod's config
+# when we figure out how to enable it on Zen2/3 APUs I'll think about making it the default