aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0260c711da55..166627955140 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -91,10 +91,12 @@ pkgname = linux-xanmod-rog
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
provides = linux-xanmod-g14
+ provides = linux-rog
conflicts = linux-xanmod-g14
pkgname = linux-xanmod-rog-headers
pkgdesc = Headers and scripts for building modules for the Linux Xanmod kernel
depends = pahole
provides = linux-xanmod-g14-headers
+ provides = linux-rog-headers
conflicts = linux-xanmod-g14-headers
diff --git a/PKGBUILD b/PKGBUILD
index cfd4526bb44f..87a5b61beab6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -336,7 +336,7 @@ _package() {
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- provides+=(linux-xanmod-g14)
+ provides+=(linux-xanmod-g14 linux-rog)
conflicts+=(linux-xanmod-g14)
cd "linux-${_major}"
@@ -362,7 +362,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=(pahole)
- provides+=(linux-xanmod-g14-headers)
+ provides+=(linux-xanmod-g14-headers linux-rog-headers)
conflicts+=(linux-xanmod-g14-headers)
cd "linux-${_major}"