aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 2 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d5ac5da7a5d..7d5d3e2102c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -100,13 +100,9 @@ pkgname = linux-xanmod-rog
depends = initramfs
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
- provides = linux-xanmod-g14
provides = linux-rog
- conflicts = linux-xanmod-g14
pkgname = linux-xanmod-rog-headers
pkgdesc = Headers and scripts for building modules for the Linux Xanmod kernel
depends = pahole
- provides = linux-xanmod-g14-headers
provides = linux-rog-headers
- conflicts = linux-xanmod-g14-headers
diff --git a/PKGBUILD b/PKGBUILD
index 9a71be40af53..6b8bb76f416e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -345,8 +345,7 @@ _package() {
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
- provides+=(linux-xanmod-g14 linux-rog)
- conflicts+=(linux-xanmod-g14)
+ provides+=(linux-rog)
cd "linux-${_major}"
local kernver="$(<version)"
@@ -371,8 +370,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
depends=(pahole)
- provides+=(linux-xanmod-g14-headers linux-rog-headers)
- conflicts+=(linux-xanmod-g14-headers)
+ provides+=(linux-rog-headers)
cd "linux-${_major}"
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"