summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fce7cb66d355..b9bb43cd34dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-cacule-uksm-cjktty
pkgdesc = Linux Xanmod. Branch with Cacule scheduler by Hamad Marri
- pkgver = 5.13.7
+ pkgver = 5.13.8
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = linux-xanmod-cacule-uksm-cjktty
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.13.7-xanmod1-cacule/patch-5.13.7-xanmod1-cacule.xz
+ source = https://github.com/xanmod/linux/releases/download/5.13.8-xanmod1-cacule/patch-5.13.8-xanmod1-cacule.xz
source = choose-gcc-optimization.sh
source = 0001-cjktty.patch::https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.13/cjktty-patches/0001-cjktty-5.13-initial-import-from-https-github.com-zhm.patch
source = 0002-UKSM.patch::https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.13/uksm-patches/0001-UKSM-for-5.13.patch
@@ -23,7 +23,7 @@ pkgbase = linux-xanmod-cacule-uksm-cjktty
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
b2sums = 9c4c12e2394dec064adff51f7ccdf389192eb27ba7906db5eda543afe3d04afca6b9ea0848a057571bf2534eeb98e1e3a67734deff82c0d3731be205ad995668
b2sums = SKIP
- b2sums = 349c53d427fc4b0cbbdb25211bc38947fef4bfea7636dba4ba6ce4ca24f9f8fdf2775a499ec4cc798bec37c4b216d25aad1a55b866d224f29ab4f4daf89f69b3
+ b2sums = 42275338efa96260802a4b0890a05f7173bdb3e7a48bd1087b818756e8ce9db385e158d43634d2654e2724968d025c1d5d3c348769438fe049942c3224558ea3
b2sums = 610a717e50339b45573dfd0b00da20ef3797053d93a5116673756f8644fbd4fbca9e82587225ebb94a5c51b0e5f1b92329d515c8c60466b41c6845ed06a7405a
b2sums = cb72248c2226b5c1a39422d9d9a79a4f9331c965a888185f421619185231a290d74e273c2323ab2c9340adfb269259825da781af423674abfbc9be909db0cc35
b2sums = 066e1d2cf209eed973957b00eebe3cbcce37b77e9ab0ef115da0aa6984ac6dea1b5d43fedd6e87dbda042b620a7684eae6c36a739f7a49e0f96ebd41867947f4
diff --git a/PKGBUILD b/PKGBUILD
index 085a8910e9e7..64bafd167984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,16 @@
## Default is: 0 => generic
## Good option if your package is for one machine: 98 => Intel native
## 99 => AMD native
-## I choose generic, you can change it by yourself
+## It will use native by default
if [ -z ${_microarchitecture+x} ]; then
- _microarchitecture=0
+ cpu=`grep vendor_id /proc/cpuinfo | awk -F: '{print $2}' | tail -1`
+ if [ $cpu == 'GenuineIntel' ]; then
+ _microarchitecture=98
+ elif [ $cpu == 'AuthenticAMD' ]; then
+ _microarchitecture=99
+ else
+ _microarchitecture=0
+ fi
fi
## Disable NUMA since most users do not have multiple processors. Breaks CUDA/NvEnc.
@@ -65,13 +72,13 @@ if [ -z ${_localmodcfg} ]; then
fi
# Tweak kernel options prior to a build via nconfig
-_makenconfig=
+_makenconfig=y
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-cacule-uksm-cjktty
_major=5.13
-pkgver=${_major}.7
+pkgver=${_major}.8
_branch=5.x
xanmod=1
pkgrel=${xanmod}
@@ -114,7 +121,7 @@ done
b2sums=('9c4c12e2394dec064adff51f7ccdf389192eb27ba7906db5eda543afe3d04afca6b9ea0848a057571bf2534eeb98e1e3a67734deff82c0d3731be205ad995668'
'SKIP'
- '349c53d427fc4b0cbbdb25211bc38947fef4bfea7636dba4ba6ce4ca24f9f8fdf2775a499ec4cc798bec37c4b216d25aad1a55b866d224f29ab4f4daf89f69b3'
+ '42275338efa96260802a4b0890a05f7173bdb3e7a48bd1087b818756e8ce9db385e158d43634d2654e2724968d025c1d5d3c348769438fe049942c3224558ea3'
'610a717e50339b45573dfd0b00da20ef3797053d93a5116673756f8644fbd4fbca9e82587225ebb94a5c51b0e5f1b92329d515c8c60466b41c6845ed06a7405a'
'cb72248c2226b5c1a39422d9d9a79a4f9331c965a888185f421619185231a290d74e273c2323ab2c9340adfb269259825da781af423674abfbc9be909db0cc35'
'066e1d2cf209eed973957b00eebe3cbcce37b77e9ab0ef115da0aa6984ac6dea1b5d43fedd6e87dbda042b620a7684eae6c36a739f7a49e0f96ebd41867947f4'