summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--exfat_fix.patch14
-rw-r--r--linux-zen.install2
4 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65cb63963a3b..cfaeb9f0d2b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Mar 5 22:41:31 UTC 2016
+# Sat Mar 19 22:44:25 UTC 2016
pkgbase = linux-zen-git
pkgdesc = Featureful kernel including various new features, code and optimizations to better suit desktops
- pkgver = 4.4.4+563154+gb0a9c23
+ pkgver = 4.5.0+575604+gace7217
pkgrel = 1
url = https://github.com/damentz/zen-kernel
arch = i686
@@ -14,9 +14,11 @@ pkgbase = linux-zen-git
options = !strip
source = linux-zen.conf
source = linux-zen.preset
- source = git://github.com/damentz/zen-kernel.git#branch=4.4/master
+ source = exfat_fix.patch
+ source = git://github.com/damentz/zen-kernel.git#branch=4.5/master
sha256sums = 6373073ad943e068478ef1373be4eb2a7e473da8743d946f1f50cd364685ab87
sha256sums = 18fe6b2664a9a740544c4cb990efe5ec933d6e64caf9e5d0a6ced92af0027c2d
+ sha256sums = 12e5e65625ef15032af32201386d9bcdef163ba721ad44cba88e149fb4ce7553
sha256sums = SKIP
pkgname = linux-zen-git
diff --git a/PKGBUILD b/PKGBUILD
index bc917eff2064..35b025e44713 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Original PKGBUILD Contributor: Patrick Bartels <p4ddy.b@gmail.com>
# Thanks to Bregol
pkgname="linux-zen-git"
-pkgver=4.4.4+563154+gb0a9c23
+pkgver=4.5.0+575604+gace7217
pkgdesc="Featureful kernel including various new features, code and optimizations to better suit desktops"
url="https://github.com/damentz/zen-kernel"
license=("GPL2")
@@ -16,9 +16,11 @@ pkgrel=1
options=("!strip")
source=("linux-zen.conf"
"linux-zen.preset"
- 'git://github.com/damentz/zen-kernel.git#branch=4.4/master')
+ "exfat_fix.patch"
+ 'git://github.com/damentz/zen-kernel.git#branch=4.5/master')
sha256sums=('6373073ad943e068478ef1373be4eb2a7e473da8743d946f1f50cd364685ab87'
'18fe6b2664a9a740544c4cb990efe5ec933d6e64caf9e5d0a6ced92af0027c2d'
+ '12e5e65625ef15032af32201386d9bcdef163ba721ad44cba88e149fb4ce7553'
'SKIP')
_CORES=1
@@ -31,6 +33,8 @@ PKGEXT='.pkg.tar'
prepare() {
cd "${srcdir}/zen-kernel"
+ patch -Np1 -i "${srcdir}/exfat_fix.patch"
+
# Number of CPU Cores
_CORES=$(cat /proc/cpuinfo|grep processor|wc -l)
if [ $_CORES -lt 1 ]; then
diff --git a/exfat_fix.patch b/exfat_fix.patch
new file mode 100644
index 000000000000..1bcb77a042a8
--- /dev/null
+++ b/exfat_fix.patch
@@ -0,0 +1,14 @@
+diff --git a/fs/exfat/exfat_super.c b/fs/exfat/exfat_super.c
+index a003a72..464de88 100644
+--- a/fs/exfat/exfat_super.c
++++ b/fs/exfat/exfat_super.c
+@@ -1375,8 +1375,7 @@ static void *exfat_follow_link(struct dentry *dentry, struct nameidata *nd)
+ #endif
+
+ const struct inode_operations exfat_symlink_inode_operations = {
+- .readlink = generic_readlink,
+- .follow_link = exfat_follow_link,
++ .readlink = generic_readlink
+ };
+
+ static int exfat_file_release(struct inode *inode, struct file *filp)
diff --git a/linux-zen.install b/linux-zen.install
index 91e522f21ce4..7ecd6a88a275 100644
--- a/linux-zen.install
+++ b/linux-zen.install
@@ -1,4 +1,4 @@
-_kernel_version=4.4.4-zen-gb0a9c23-dirty
+_kernel_version=4.5.0-zen-gace7217-dirty
_r="\033[00;31m"
_y="\033[00;33m"