summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--libtirpc.patch22
3 files changed, 37 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e497327af1ff..95377112ed0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Wed Nov 7 18:00:45 UTC 2018
pkgbase = linuxcnc-sim
pkgdesc = It can interpret G-code and simulate a CNC machine (formerly EMC2).
pkgver = 2.7.12
@@ -24,10 +26,12 @@ pkgbase = linuxcnc-sim
source = boost.patch
source = image-to-gcode.patch
source = linuxcnc-sim.sh
+ source = libtirpc.patch
md5sums = SKIP
md5sums = ba6948dc5dc155849f55039e454cdbd6
md5sums = c31d34a7ba567bd664f362a52f8bb03b
md5sums = 3fb3f231cfefdfe1fa4d600ecbf4a3cb
+ md5sums = 42770a1aa791172358700e4d5af335ed
pkgname = linuxcnc-sim
diff --git a/PKGBUILD b/PKGBUILD
index d3653919e07b..e4b470825536 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,12 +11,13 @@ url="http://linuxcnc.org/"
depends=('bc' 'bwidget' 'tcl' 'tk' 'xorg-server' 'python2-imaging' 'tkimg' 'python2-gtkglext' 'tclx' 'boost' 'boost-libs' 'libtirpc')
install=$pkgname.install
_gitname='linuxcnc'
-source=($_gitname::"git://github.com/LinuxCNC/linuxcnc.git#tag=v$pkgver" 'boost.patch' 'image-to-gcode.patch' 'linuxcnc-sim.sh')
+source=($_gitname::"git://github.com/LinuxCNC/linuxcnc.git#tag=v$pkgver" 'boost.patch' 'image-to-gcode.patch' 'linuxcnc-sim.sh' 'libtirpc.patch')
#source=($_gitname::'git://git.linuxcnc.org/git/linuxcnc.git#tag=739df958aca9d246daad36f439c82bfbeac681b9' 'boost.patch')
md5sums=('SKIP'
- 'ba6948dc5dc155849f55039e454cdbd6'
- 'c31d34a7ba567bd664f362a52f8bb03b'
- '3fb3f231cfefdfe1fa4d600ecbf4a3cb')
+ 'ba6948dc5dc155849f55039e454cdbd6'
+ 'c31d34a7ba567bd664f362a52f8bb03b'
+ '3fb3f231cfefdfe1fa4d600ecbf4a3cb'
+ '42770a1aa791172358700e4d5af335ed')
makedepends=('git')
PKGEXT='.pkg.tar'
@@ -37,8 +38,14 @@ build () {
# #Another Python fix
# cd $srcdir/$pkgname-$pkgver
# patch -Np1 < $srcdir/jepler-modsilent.patch
+
+ patch -Np2 -i $srcdir/libtirpc.patch
+
# cd $srcdir/$pkgname-$pkgver/src
+# CFLAGS+=" -I/usr/include/tirpc/"
+ CXXFLAGS+=" -I/usr/include/tirpc/"
CPPFLAGS+=" -I/usr/include/tirpc/"
+ INCLUDE+=" -I/usr/include/tirpc/"
LDFLAGS+=" -ltirpc"
./autogen.sh
./configure --with-realtime=uspace --without-libmodbus --prefix=/usr --with-python=/usr/bin/python2.7 --enable-non-distributable=yes
diff --git a/libtirpc.patch b/libtirpc.patch
new file mode 100644
index 000000000000..58f1fa1c0486
--- /dev/null
+++ b/libtirpc.patch
@@ -0,0 +1,22 @@
+diff --git a/src/Makefile b/src/Makefile
+index a99e52686..9b2b5705e 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -139,7 +139,7 @@ ULAPISRCS := rtapi/$(RTPREFIX)_ulapi.c
+
+ # Each item in INCLUDES is transformed into a -I directive later on
+ # The top directory is always included
+-INCLUDES := .
++INCLUDES := . /usr/include/tirpc/
+
+ USERSRCS :=
+ PROGRAMS :=
+@@ -203,6 +203,8 @@ else
+ LDFLAGS := -Wl,-rpath-link,../lib
+ endif
+
++LDFLAGS += -ltirpc
++
+ # Rules to make .o (object) files
+ $(sort $(CUSEROBJS)) : objects/%.o: %.c
+ $(ECHO) Compiling $<