summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--image-to-gcode.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23f2b23e208e..6839a55496c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linuxcnc-sim
pkgdesc = It can interpret G-code and simulate a CNC machine (formerly EMC2).
- pkgver = 20160411
+ pkgver = 20160419
pkgrel = 1
url = http://linuxcnc.org/
install = linuxcnc-sim.install
@@ -22,8 +22,10 @@ pkgbase = linuxcnc-sim
depends = boost-libs
source = linuxcnc::git://git.linuxcnc.org/git/linuxcnc.git
source = boost.patch
+ source = image-to-gcode.patch
md5sums = SKIP
md5sums = ba6948dc5dc155849f55039e454cdbd6
+ md5sums = c31d34a7ba567bd664f362a52f8bb03b
pkgname = linuxcnc-sim
diff --git a/PKGBUILD b/PKGBUILD
index 009e577e600e..f27a4ac6b47e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alec Ari <neotheuser@ymail.com>
pkgname=linuxcnc-sim
-pkgver=20160411
+pkgver=20160419
pkgrel=1
pkgdesc="It can interpret G-code and simulate a CNC machine (formerly EMC2)."
arch=('i686' 'x86_64')
@@ -11,10 +11,11 @@ url="http://linuxcnc.org/"
depends=('bc' 'bwidget' 'tcl' 'tk' 'xorg-server' 'python2-libgnome' 'python2-imaging' 'tkimg' 'python2-gtkglext' 'tclx' 'boost' 'boost-libs')
install=$pkgname.install
_gitname='linuxcnc'
-source=($_gitname::'git://git.linuxcnc.org/git/linuxcnc.git' 'boost.patch')
+source=($_gitname::'git://git.linuxcnc.org/git/linuxcnc.git' 'boost.patch' 'image-to-gcode.patch')
#source=($_gitname::'git://git.linuxcnc.org/git/linuxcnc.git#tag=739df958aca9d246daad36f439c82bfbeac681b9' 'boost.patch')
md5sums=('SKIP'
- 'ba6948dc5dc155849f55039e454cdbd6')
+ 'ba6948dc5dc155849f55039e454cdbd6'
+ 'c31d34a7ba567bd664f362a52f8bb03b')
makedepends=('git')
PKGEXT='.pkg.tar'
@@ -26,6 +27,8 @@ pkgver() {
build () {
find . -iname fixpaths.py -o -iname checkglade|xargs perl -p -i -e "s/python/python2/"
cd $srcdir/$_gitname/src
+ pwd
+ patch -p0 <../../image-to-gcode.patch
# patch -p1 <../../boost.patch
# #This Makefile line fixes a seg fault due to changed CFLAGS
# cp -PR $srcdir/Makefile $srcdir/$pkgname-$pkgver/src/Makefile
diff --git a/image-to-gcode.patch b/image-to-gcode.patch
new file mode 100644
index 000000000000..95f4607328d0
--- /dev/null
+++ b/image-to-gcode.patch
@@ -0,0 +1,11 @@
+--- image-to-gcode 2016-04-23 08:02:14.000000000 +0200
++++ emc/usr_intf/axis/scripts/image-to-gcode.py 2016-04-23 08:00:16.004178946 +0200
+@@ -23,7 +23,7 @@
+ import gettext;
+ gettext.install("linuxcnc", localedir=os.path.join(BASE, "share", "locale"), unicode=True)
+
+-import Image
++from PIL import Image
+
+ try:
+ import numpy.numarray as numarray