summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD30
3 files changed, 19 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f2b60c12a1a..a3c82ea178eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = linvst
- pkgdesc = enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's
- pkgver = 2.3.r44.2a4b91e
+ pkgdesc = Windows VST2 wrapper that allows them to be used as Linux VST2s in compatible DAWs using Wine.
+ pkgver = 4.7
pkgrel = 1
url = https://github.com/osxmidi/LinVst
arch = x86_64
- makedepends = git
+ license = GPL3
depends = wine
- source = git+https://github.com/osxmidi/LinVst.git
- source = https://download.steinberg.net/sdk_downloads/vstsdk369_01_03_2018_build_132.zip
- sha256sums = SKIP
- sha256sums = 7c6c2a5f0bcbf8a7a0d6a42b782f0d3c00ec8eafa4226bbf2f5554e8cd764964
+ source = linvst-4.7.tar.gz::https://github.com/osxmidi/LinVst/archive/refs/tags/4.7.tar.gz
+ sha256sums = 96cf075eebb9db4d23f6fe7327b70496320f3d751e5ec24b7ffa3e29c750c8d1
pkgname = linvst
-
diff --git a/.gitignore b/.gitignore
index 3d592ee0e261..c222da81a9c5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,6 @@ pkg/
src
*.xz
*.zip
+*.pkg.*
+linvst-*.tar.gz
+linvst/
diff --git a/PKGBUILD b/PKGBUILD
index 3610ccb4ee74..4c64d02bd343 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,22 @@
+# Maintainer: Julia DeMille <me@jdemille.com>
+# Contributor: David <ottodavid@gmx.net>
pkgname=linvst
-pkgver=2.3.r44.2a4b91e
+pkgver=4.7
pkgrel=1
-pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's"
+license=('GPL3')
+pkgdesc="Windows VST2 wrapper that allows them to be used as Linux VST2s in compatible DAWs using Wine."
arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
depends=('wine')
-makedepends=('git')
-source=('git+https://github.com/osxmidi/LinVst.git' 'https://download.steinberg.net/sdk_downloads/vstsdk369_01_03_2018_build_132.zip')
-sha256sums=('SKIP'
- '7c6c2a5f0bcbf8a7a0d6a42b782f0d3c00ec8eafa4226bbf2f5554e8cd764964')
-
-pkgver() {
- cd "LinVst"
- printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-}
-
-prepare() {
- ln -sf "${srcdir}/VST_SDK/VST2_SDK/pluginterfaces" "LinVst/"
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/osxmidi/LinVst/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('96cf075eebb9db4d23f6fe7327b70496320f3d751e5ec24b7ffa3e29c750c8d1')
build() {
- cd "${srcdir}/LinVst"
- make -f Makefile-embed-6432 DESTDIR="${pkgdir}" all
+ cd "${srcdir}/LinVst-${pkgver}"
+ make DESTDIR="${pkgdir}" all
}
package() {
- cd "${srcdir}/LinVst"
- make -f Makefile-embed-6432 DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/lib/vst/" install
+ cd "${srcdir}/LinVst-${pkgver}"
+ make DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/lib/vst/" install
}