summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
-rw-r--r--liquibase.profile3
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b56c57dd570e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = liquibase
+ pkgdesc = VCS source control tailored for database management
+ pkgver = 3.4.1
+ pkgrel = 1
+ url = http://www.liquibase.org/
+ arch = any
+ license = Apache
+ depends = java-environment
+ options = !strip
+ source = https://github.com/liquibase/liquibase/releases/download/liquibase-parent-3.4.1/liquibase-3.4.1-bin.tar.gz
+ source = liquibase.profile
+ sha256sums = 693919918e217e7a88c5140e82f279f31f636233a62cd2108abdafa4f3ed0a02
+ sha256sums = 7c1939e5b1aee63db199c86989726bbdf81102784512ed69f8595fddf80c30c0
+
+pkgname = liquibase
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3c50fdff2a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id$
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Andreas Pieber <anpieber@gmail.com>
+
+set -u
+pkgname='liquibase'
+pkgver='3.4.1'
+pkgrel='1'
+pkgdesc='VCS source control tailored for database management'
+arch=('any')
+url="http://www.liquibase.org/"
+license=('Apache')
+depends=('java-environment')
+_giturl="https://github.com/liquibase/${pkgname}"
+_verwatch=("${_giturl}/releases" "${_giturl#*github.com}/releases/download/liquibase-parent-[^/]\+/liquibase-\([0-9\.]\+\)-bin.tar.gz" 'l')
+source=("https://github.com/liquibase/${pkgname}/releases/download/liquibase-parent-${pkgver}/liquibase-${pkgver}-bin.tar.gz"
+ "liquibase.profile")
+sha256sums=('693919918e217e7a88c5140e82f279f31f636233a62cd2108abdafa4f3ed0a02'
+ '7c1939e5b1aee63db199c86989726bbdf81102784512ed69f8595fddf80c30c0')
+options=('!strip')
+
+package() {
+ set -u
+ # install profile file
+ #install -Dpm644 "${srcdir}/liquibase.profile" "${pkgdir}/etc/profile.d/liquibase.sh"
+ # sed makes it easy to not forget our underprivileged csh users
+ #install -Dpm644 <(sed -e 's:export :setenv :g' -e 's:=: :g' "${srcdir}/liquibase.profile") "${pkgdir}/etc/profile.d/liquibase.csh"
+
+ # This binary link removes the need for the profile files that require a logout to make work
+ install -d "${pkgdir}/usr/bin"
+ ln -sf '/opt/liquibase/liquibase' "${pkgdir}/usr/bin/liquibase"
+
+ # create folders
+ install -d "${pkgdir}/opt/liquibase"
+
+ # move liquibase tar content to /opt/liquibase
+ find "${srcdir}/." -maxdepth 1 -not -type l -not -name '*.' -exec mv '{}' "${pkgdir}/opt/liquibase/" ';'
+ #cp -r ${srcdir}/* ${pkgdir}/opt/liquibase
+
+ # make liquibase executable
+ chmod 755 "${pkgdir}/opt/liquibase/liquibase"
+
+ # remove files for other platforms
+ rm -f "${pkgdir}/opt/liquibase"/{liquibase.bat,liquibase.spec}
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgbase}/"
+ ln -sf '/opt/liquibase/LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE.txt"
+ set +u
+}
+set +u
diff --git a/liquibase.profile b/liquibase.profile
new file mode 100644
index 000000000000..b02de8c1a28d
--- /dev/null
+++ b/liquibase.profile
@@ -0,0 +1,3 @@
+export LIQUIBASE_HOME="/opt/liquibase/"
+export PATH="${PATH}:${LIQUIBASE_HOME}"
+