summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 148e081f4422..33f3d63ea215 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = liquidshell-git
pkgdesc = liquidshell is an alternative to plasmashell
- pkgver = r64.9cc1429
+ pkgver = r65.87b14e3
pkgrel = 1
url = https://cgit.kde.org/liquidshell.git/
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = liquidshell-git
depends = bluez-qt
depends = kcmutils
depends = knewstuff
- source = liquidshell-git-r64.9cc1429::git+git://anongit.kde.org/liquidshell.git
+ source = git+git://anongit.kde.org/liquidshell.git
sha256sums = SKIP
pkgname = liquidshell-git
diff --git a/PKGBUILD b/PKGBUILD
index 83df7e436a1a..f61e99927096 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
pkgname=liquidshell-git
-pkgver=r64.9cc1429
+_gitname=liquidshell
+pkgver=r65.87b14e3
pkgrel=1
pkgdesc='liquidshell is an alternative to plasmashell'
arch=('x86_64')
@@ -11,19 +12,19 @@ url='https://cgit.kde.org/liquidshell.git/'
license=('GPL3')
depends=('networkmanager-qt' 'bluez-qt' 'kcmutils' 'knewstuff')
makedepends=('cmake' 'extra-cmake-modules' 'git')
-source=("${pkgname}-${pkgver}::git+git://anongit.kde.org/liquidshell.git")
+source=("git+git://anongit.kde.org/liquidshell.git")
sha256sums=('SKIP')
pkgver() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${_gitname}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${srcdir}/${_gitname}
mkdir build && cd build
cmake ..
@@ -33,6 +34,6 @@ build() {
package() {
- install -Dm755 ${srcdir}/${pkgname}-${pkgver}/build/liquidshell ${pkgdir}/usr/bin/liquidshell
+ install -Dm755 ${srcdir}/${_gitname}/build/liquidshell ${pkgdir}/usr/bin/liquidshell
}