summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
-rw-r--r--lirc.install13
-rw-r--r--lirc.logrotate5
-rw-r--r--lirc.tmpfiles1
-rw-r--r--lircd.service10
7 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c56953220574
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Tue Mar 1 13:30:30 UTC 2016
+pkgbase = lirc-irdroid
+ pkgdesc = Linux Infrared Remote Control utils (irdroid version)
+ pkgver = 0.8.7
+ pkgrel = 1
+ url = http://www.lirc.org/
+ install = lirc.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ depends = alsa-lib
+ depends = libx11
+ depends = libftdi-compat
+ depends = libirman
+ provides = lirc
+ provides = lirc-utils
+ conflicts = lirc
+ conflicts = lirc-utils
+ replaces = lirc
+ replaces = lirc-utils
+ backup = etc/lirc/lirc_options.conf
+ backup = etc/lirc/lircd.conf
+ backup = etc/lirc/lircmd.conf
+ source = lirc.tar.gz::http://www.irdroid.com/wp-content/plugins/download-monitor/download.php?id=16
+ source = lirc.logrotate
+ source = lirc.tmpfiles
+ source = lircd.service
+ md5sums = dba13e4d2113129abd98ea6548ba6183
+ md5sums = 3deb02604b37811d41816e9b4385fcc3
+ md5sums = febf25c154a7d36f01159e84f26c2d9a
+ md5sums = 64e7e7d4a6befe57c6e42777fdf0a36f
+
+pkgname = lirc-irdroid
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4c88fecc8406
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.tar.xz
+lirc.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..101cc5680f61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Paul Mattal <paul@archlinux.org>
+
+pkgname=lirc-irdroid
+pkgver=0.8.7
+pkgrel=1
+pkgdesc="Linux Infrared Remote Control utils (irdroid version)"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://www.lirc.org/"
+license=('GPL')
+depends=('alsa-lib' 'libx11' 'libftdi-compat' 'libirman')
+# makedepends=('help2man' 'alsa-lib' 'libx11' 'libftdi-compat' 'libirman' 'libxslt' 'python')
+# optdepends=('python: for lirc-setup, irdb-get and pronto2lirc')
+provides=('lirc' 'lirc-utils')
+conflicts=('lirc' 'lirc-utils')
+replaces=('lirc' 'lirc-utils')
+backup=('etc/lirc/lirc_options.conf' 'etc/lirc/lircd.conf' 'etc/lirc/lircmd.conf')
+install=lirc.install
+source=("lirc.tar.gz::http://www.irdroid.com/wp-content/plugins/download-monitor/download.php?id=16"
+ lirc.logrotate
+ lirc.tmpfiles
+ lircd.service)
+md5sums=('dba13e4d2113129abd98ea6548ba6183'
+ '3deb02604b37811d41816e9b4385fcc3'
+ 'febf25c154a7d36f01159e84f26c2d9a'
+ '64e7e7d4a6befe57c6e42777fdf0a36f')
+
+build() {
+ cd "${srcdir}/irtoy"
+
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --localstatedir=/var \
+ --with-transmitter --with-driver=usb_irtoy --enable-sandboxed
+ make
+}
+
+package() {
+ cd "${srcdir}/irtoy"
+
+ # dirtyfix: For some reason the "make install" fails if this directory does
+ # not exist (it tries to remove it)
+ mkdir -p "${pkgdir}/var/run/lirc"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${srcdir}"/lirc.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/lirc.conf
+ install -Dm644 "${srcdir}"/lirc.logrotate "${pkgdir}"/etc/logrotate.d/lirc
+ install -Dm644 "${srcdir}"/lircd.service "${pkgdir}"/usr/lib/systemd/system/lircd.service
+
+ rmdir "${pkgdir}"/var/{run/lirc/,run/,}
+}
diff --git a/lirc.install b/lirc.install
new file mode 100644
index 000000000000..f7faa07eb0b6
--- /dev/null
+++ b/lirc.install
@@ -0,0 +1,13 @@
+post_install() {
+ systemd-tmpfiles --create lirc.conf
+}
+
+post_upgrade() {
+ post_install
+
+ if [[ "$(vercmp $2 1:0.9.1-1)" -lt 0 ]]; then
+ echo ':: lirc.service and lircm.service have been replaced'
+ echo ' by the upstream unit files lircd.service and'
+ echo ' lircmd.service.'
+ fi
+}
diff --git a/lirc.logrotate b/lirc.logrotate
new file mode 100644
index 000000000000..623c4f328ed2
--- /dev/null
+++ b/lirc.logrotate
@@ -0,0 +1,5 @@
+/var/log/lircd {
+ missingok
+ notifempty
+ delaycompress
+}
diff --git a/lirc.tmpfiles b/lirc.tmpfiles
new file mode 100644
index 000000000000..0b80e2e479b2
--- /dev/null
+++ b/lirc.tmpfiles
@@ -0,0 +1 @@
+d /run/lirc 0755 root root -
diff --git a/lircd.service b/lircd.service
new file mode 100644
index 000000000000..54f1d714ed45
--- /dev/null
+++ b/lircd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LIRC Infrared Signal Decoder
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/sbin/lircd --nodaemon
+
+[Install]
+WantedBy=multi-user.target