summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD44
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..335e343f34fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Oct 12 21:10:57 UTC 2016
+pkgbase = liri-themes-git
+ pkgdesc = Themes for uniform look and feel throughout Liri OS
+ pkgver = 20161012.a5808c4
+ pkgrel = 1
+ url = http://liri.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = liri-git
+ license = GPL3
+ makedepends = git
+ makedepends = extra-cmake-modules
+ provides = liri-themes
+ conflicts = liri-themes
+ replaces = liri-themes
+ source = themes::git://github.com/lirios/themes.git#branch=develop
+ md5sums = SKIP
+
+pkgname = liri-themes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad8b485dce73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=liri-themes-git
+pkgver=20161012.a5808c4
+pkgrel=1
+pkgdesc="Themes for uniform look and feel throughout Liri OS"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='http://liri.io'
+license=('GPL3')
+makedepends=('git' 'extra-cmake-modules')
+conflicts=('liri-themes')
+replaces=('liri-themes')
+provides=('liri-themes')
+groups=('liri-git')
+
+_gitroot="git://github.com/lirios/themes.git"
+_gitbranch=develop
+_gitname=themes
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../${_gitname} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}