summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e580ec3269f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Jan 1 16:17:42 UTC 2017
+pkgbase = liri-wallpapers
+ pkgdesc = Wallpapers for Liri OS
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://liri.io
+ arch = any
+ groups = liri
+ license = GPL3
+ makedepends = extra-cmake-modules
+ conflicts = liri-wallpapers-git
+ source = https://github.com/lirios/wallpapers/releases/download/v0.9.0/liri-wallpapers-0.9.0.tar.xz
+ sha256sums = 98112d8febfe1aaf115285a061d4450c13bd7a1197b9539ac04437637745604c
+
+pkgname = liri-wallpapers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8e7bf49a754
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+_modulename=wallpapers
+
+pkgname=liri-${_modulename}
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Wallpapers for Liri OS"
+arch=('any')
+url='https://liri.io'
+license=('GPL3')
+makedepends=('extra-cmake-modules')
+conflicts=('liri-wallpapers-git')
+groups=('liri')
+source=("https://github.com/lirios/${_modulename}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('98112d8febfe1aaf115285a061d4450c13bd7a1197b9539ac04437637745604c')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}