summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e10686128d1a..a7aed8db6626 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Fri Feb 1 12:44:39 UTC 2019
pkgbase = lisp
- pkgdesc = Wrapper scripts for SBCL, for programming in Common Lisp
+ pkgdesc = Wrapper scripts to make it easier to get started with Common Lisp
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xyproto/lisp
arch = any
license = GPL2
makedepends = git
depends = sbcl
- source = git+https://github.com/xyproto/lisp#tag=1.2.0
+ source = git+https://github.com/xyproto/lisp#commit=445ef31a19a5153f5c12099c3db61689212f85eb
sha256sums = SKIP
pkgname = lisp
diff --git a/PKGBUILD b/PKGBUILD
index 9210be07f81c..91def8d13b2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,20 @@
pkgname=lisp
pkgver=1.2.0
-pkgrel=1
-pkgdesc='Wrapper scripts for SBCL, for programming in Common Lisp'
+pkgrel=2
+pkgdesc='Wrapper scripts to make it easier to get started with Common Lisp'
arch=(any)
url='https://github.com/xyproto/lisp'
license=(GPL2)
depends=(sbcl)
makedepends=(git)
-source=("git+$url#tag=$pkgver")
-sha256sums=(SKIP)
+source=("git+$url#commit=445ef31a19a5153f5c12099c3db61689212f85eb") # tag: 1.2.0
+sha256sums=('SKIP')
check() {
- getent passwd "$USER" | cut -d: -f5 | make -C $pkgname test
+ echo "$LOGNAME" | make -C $pkgname test
}
package() {
DESTDIR="$pkgdir" make -C "$pkgname" install
}
-
-# vim: ts=2 sw=2 et:
-