summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD36
-rwxr-xr-xlhd-qt.sh3
-rw-r--r--litecoinhd-qt.desktop14
-rw-r--r--litecoinhd128.pngbin0 -> 14852 bytes
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67e9d5a16f90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = litecoinhd-qt
+ pkgver = 0.16.6
+ pkgrel = 1
+ url = https://ltchd.io
+ arch = x86_64
+ license = MIT
+ noextract = COPYING
+ source = https://github.com/ltchd2019/litecoinhd-qt/releases/download/ltchd-v0.16.6/ltchd-v0.16.6.0-fb64d89-x86_64-linux-gnu.tar.gz
+ source = https://raw.githubusercontent.com/ltchd2019/litecoinhd-qt/ltchd-v0.16.6/COPYING
+ source = litecoinhd128.png
+ source = litecoinhd-qt.desktop
+ source = lhd-qt.sh
+ sha256sums = c2f1a6cb8b114f2d0a6e169b52e2f2fba2c06d95ecefe776d51a60972529d205
+ sha256sums = e4c2b5dd7474e599e958324fd4eb47aa67aad650e73e39e8358df2907d4af386
+ sha256sums = 2630ae1bfc1393f279dcbae517ff1e90e4bdc8e7fe652f7429f6231ad9af6730
+ sha256sums = d990b06d30aae8c633f36fda986015921f33a9b7a326da0b471f8daa739e4fc4
+ sha256sums = fb1aec170fb65a89f8c6bbef0f70568c70d2ba8d54d18f7dd3650144bff13f6b
+
+pkgname = litecoinhd-qt
+ pkgdesc = LitecoinHD is a peer-to-peer network based digital currency - Qt
+ depends = boost-libs
+ depends = libevent
+ depends = qt5-base
+ depends = miniupnpc
+ depends = libminiupnpc.so
+ depends = qrencode
+ depends = protobuf
+ depends = zeromq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3472c78fac8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Ben Westover <kwestover [dot] kw [at] gmail [dot] com>
+
+pkgname=litecoinhd-qt
+pkgver=0.16.6
+pkgrel=1
+commit=fb64d89
+arch=('x86_64')
+url="https://ltchd.io"
+license=('MIT')
+source=("https://github.com/ltchd2019/$pkgname/releases/download/ltchd-v$pkgver/ltchd-v$pkgver.0-$commit-x86_64-linux-gnu.tar.gz"
+ "https://raw.githubusercontent.com/ltchd2019/$pkgname/ltchd-v$pkgver/COPYING"
+ "litecoinhd128.png"
+ "litecoinhd-qt.desktop"
+ "lhd-qt.sh")
+noextract=('COPYING')
+sha256sums=('c2f1a6cb8b114f2d0a6e169b52e2f2fba2c06d95ecefe776d51a60972529d205'
+ 'e4c2b5dd7474e599e958324fd4eb47aa67aad650e73e39e8358df2907d4af386'
+ '2630ae1bfc1393f279dcbae517ff1e90e4bdc8e7fe652f7429f6231ad9af6730'
+ 'd990b06d30aae8c633f36fda986015921f33a9b7a326da0b471f8daa739e4fc4'
+ 'fb1aec170fb65a89f8c6bbef0f70568c70d2ba8d54d18f7dd3650144bff13f6b')
+
+package() {
+ pkgdesc="LitecoinHD is a peer-to-peer network based digital currency - Qt"
+ depends=(boost-libs libevent qt5-base miniupnpc libminiupnpc.so qrencode protobuf zeromq)
+
+ install -Dm755 ltchd-v$pkgver/bin/ltchd-qt $pkgdir/usr/bin/ltchd-qt
+ install -Dm644 ltchd-v$pkgver/share/man/man1/ltchd-qt.1 $pkgdir/usr/share/man/man1/ltchd-qt.1
+
+ install -Dm755 lhd-qt.sh $pkgdir/usr/local/bin/lhd-qt
+ install -Dm644 litecoinhd128.png $pkgdir/usr/share/pixmaps/ltchd128.png
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/ltchd-qt.desktop
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/ltchd/COPYING
+
+ mkdir -p $pkgdir/usr/lib/ltchd
+ cp -r ltchd-v$pkgver/lib/* $pkgdir/usr/lib/ltchd
+}
diff --git a/lhd-qt.sh b/lhd-qt.sh
new file mode 100755
index 000000000000..e53cbb800f8e
--- /dev/null
+++ b/lhd-qt.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+mkdir -p $HOME/.litecoinhd
+LD_LIBRARY_PATH=/usr/lib/ltchd ltchd-qt -datadir=$HOME/.litecoinhd/ "$@"
diff --git a/litecoinhd-qt.desktop b/litecoinhd-qt.desktop
new file mode 100644
index 000000000000..9887d1b0a9cf
--- /dev/null
+++ b/litecoinhd-qt.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Name=LitecoinHD Core
+Comment=Connect to the LitecoinHD P2P Network
+Comment[de]=Verbinde mit dem LitecoinHD peer-to-peer Netzwerk
+Comment[fr]=LitecoinHD, monnaie virtuelle cryptographique pair à pair
+Comment[tr]=LitecoinHD, eşten eşe kriptografik sanal para birimi
+Exec=lhd-qt %u
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/ltchd128.png
+MimeType=x-scheme-handler/ltchd;
+Categories=Office;Finance;P2P;Network;Qt;
+StartupWMClass=litecoinhd-qt
diff --git a/litecoinhd128.png b/litecoinhd128.png
new file mode 100644
index 000000000000..0a88761a3cc9
--- /dev/null
+++ b/litecoinhd128.png
Binary files differ