summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 583b1b347a4e..8128fd177c5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = liveusb-builder-git
pkgdesc = A script suite to create multiboot USB stick for GNU/Linux distributions
- pkgver = 2021.04.3.gcc427a7
+ pkgver = 2021.04.9.gec66632
pkgrel = 1
url = https://github.com/mytbk/liveusb-builder
arch = any
license = GPL3
depends = util-linux
depends = libarchive
- depends = udevil
depends = wget
depends = syslinux
depends = mtools
depends = grub
+ optdepends = udisks2: mount partitions on USB drives without being root
+ optdepends = udevil: mount partitions on USB drives and ISO images without being root
source = git+https://git.wehack.space/liveusb-builder
source = buildlive
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1fd4af0082c4..20f691346408 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# Maintainer: Iru Cai <mytbk920423@gmail.com>
pkgname=liveusb-builder-git
-pkgver=2021.04.3.gcc427a7
+pkgver=2021.04.9.gec66632
pkgrel=1
pkgdesc='A script suite to create multiboot USB stick for GNU/Linux distributions'
license=('GPL3')
-depends=('util-linux' 'libarchive' 'udevil' 'wget' 'syslinux' 'mtools' 'grub')
+depends=('util-linux' 'libarchive' 'wget' 'syslinux' 'mtools' 'grub')
+optdepends=('udisks2: mount partitions on USB drives without being root'
+ 'udevil: mount partitions on USB drives and ISO images without being root')
arch=('any')
url='https://github.com/mytbk/liveusb-builder'
source=('git+https://git.wehack.space/liveusb-builder'
@@ -24,5 +26,4 @@ package() {
pkgver() {
cd "$srcdir/liveusb-builder"
git describe --always | sed 's/-/./g'
-
}