summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bf8f238e0db..737a553779ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
# Generated by mksrcinfo v8
-# Mon Feb 22 21:29:05 UTC 2016
+# Mon Oct 10 21:25:05 UTC 2016
pkgbase = livewallpaper
pkgdesc = OpenGL powered animated wallpapers with configuration utility, autostart, and application indicator.
pkgver = 0.5.0
pkgrel = 1
url = https://launchpad.net/livewallpaper
install = livewallpaper.install
- arch = any
+ arch = x86_64
+ arch = i686
license = GPL3
makedepends = intltool
makedepends = xcftools
makedepends = cmake
- depends = libgl
+ makedepends = vala
depends = libpeas
- depends = libx11
+ depends = glew
+ depends = upower
+ depends = libappindicator-gtk3
+ depends = gobject-introspection
depends = python
- depends = python-numpy
depends = python-cairo
depends = python-opengl
- depends = gtk3
- depends = gobject-introspection
- depends = libappindicator-gtk3
provides = livewallpaper
provides = livewallpaper-indicator
provides = livewallpaper-config
diff --git a/PKGBUILD b/PKGBUILD
index 06fc4ec5b5a8..f804d39cb088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,12 @@ pkgname=livewallpaper
pkgver=0.5.0
pkgrel=1
pkgdesc="OpenGL powered animated wallpapers with configuration utility, autostart, and application indicator."
-arch=(any)
+arch=('x86_64' 'i686')
url="https://launchpad.net/livewallpaper"
license=('GPL3')
-makedepends=('intltool' 'xcftools' 'cmake')
-depends=('libgl' 'libpeas' 'libx11'
- 'python' 'python-numpy' 'python-cairo' 'python-opengl'
- 'gtk3' 'gobject-introspection' 'libappindicator-gtk3')
+makedepends=('intltool' 'xcftools' 'cmake' 'vala')
+depends=('libpeas' 'glew' 'upower' 'libappindicator-gtk3' 'gobject-introspection'
+ 'python' 'python-cairo' 'python-opengl')
provides=('livewallpaper' 'livewallpaper-indicator' 'livewallpaper-config')
source=(https://launchpad.net/livewallpaper/0.5/0.5.0/+download/livewallpaper-0.5.0.tar.gz)
@@ -19,7 +18,17 @@ install=livewallpaper.install
prepare() {
cd "$srcdir/$pkgname-$pkgver"
+
+ # Add inexisting folder
sed -i '/add_subdirectory(debian)/d' CMakeLists.txt
+ # Disable doc generation (needs gtk-doc)
+ sed -i '/add_subdirectory(doc)/d' CMakeLists.txt
+ # Please use python3
+ sed -i '1i #!/usr/bin/python3' plugins/circles/circles.py
+ sed -i '1i #!/usr/bin/python3' plugins/photoslide/photoslide.py
+ # Fix old API
+ sed -i -e 's/fromstring/frombytes/g' plugins/photoslide/photoslide.py
+ sed -i -e 's/tostring/tobytes/g' plugins/photoslide/photoslide.py
}
build() {