summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG42
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD57
3 files changed, 88 insertions, 15 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 0fb90192aac5..c74ac0cfa761 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,48 @@
Version history
===============
+0.9.18
+------
+
+2018-07-01
+
+lemforum: Behind Bars 7/10->8/12 to remove backroute. One Step Off
+80/80->20/20. Segmentation Fault 20/40->21/40. Merge Sort, hollow terrain
+to remove red herrings. Rhapsody in Blue, aligned traps to terrain
+(removes 1-pixel gaps). Removed obviously unassignable
+imploders/exploders/cubers according to save requirement.
+
+Rubix's levels: Lost Underground, cap reachable ceiling more clearly.
+Removed obviously unassignable imploders/exploders/cubers.
+
+Tiles: Raymanni's improved carnival exit, cleaner large proxima/tiles/orange2.
+
+Fix #23: Don't show obsolete replay arrows/pickaxes/sounds when you
+framestep after a quickload.
+
+Fix #346: When you watch a replay, interrupt, and win, the solution
+replay is auto-saved.
+
+Singleplayer exits the level after nuking instead of prompting to
+framestep back.
+
+On display creation, the mouse cursor centers on the Lix window. This prevents
+edge scrolling when watching replays from the command line.
+
+Fix #340: For translations, use format strings (containing %s, %d with runtime
+checks) instead of several concatenated translated strings.
+
+Fix #341: Translate the output of the replay verifier.
+
+Fix #342: Better grammar, fewer Denglish (English words in the German
+translation even though good German words exist), add umlauts. Thanks to
+Wuzzy for this patch!
+
+In displayed strings, use typographical quotation marks. In file/shell output,
+use double quotes both to begin and end instead of asymmetric quotes.
+
+
+
0.9.17
------
diff --git a/.SRCINFO b/.SRCINFO
index 0739220e1dec..2441408a2404 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.17
+ pkgver = 0.9.18
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -13,7 +13,7 @@ pkgbase = lix
depends = allegro
depends = enet
conflicts = lix-git
- source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.17
+ source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.18
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 80e314814cc3..c65e608946ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix
-pkgver=0.9.17
+pkgver=0.9.18
pkgrel=1
changelog=.CHANGELOG
conflicts=("${pkgname}-git")
@@ -14,7 +14,7 @@ sha512sums=('SKIP'
'52d49562cd9be4eec76b464153af1cce2211fdbd6113a6a60df042f7e8f7e6a8f1942df883dfaaa6c1bbfea004c4154d884dfa767e25fa3fadf9c58be1103fe6')
_pkgname=${pkgname}
-# template start; name=lix; version=0.6;
+# template start; name=lix; version=0.7;
pkgdesc="An action-puzzle game inspired by Lemmings"
arch=('i686' 'x86_64')
url="http://www.lixgame.com/"
@@ -27,7 +27,8 @@ build()
cd "${srcdir}/${_pkgname}"
_r=0
- # force an upgrade of the dependencies to the local folder, without --cache=local they get added to the users home directory
+ # force an upgrade of the dependencies to the local folder, without
+ # --cache=local they get added to the users home directory
dub upgrade --cache=local
# add local dependencies to search path
@@ -41,7 +42,8 @@ build()
# force FHS compatibility with '-b releaseXDG'
dub build -f -b releaseXDG --cache=local || _r=$?
- # remove local dependencies from search path so dub don't find them later again
+ # remove local dependencies from search path so dub don't find them
+ # later again
dub remove-local allegro-*/allegro
dub remove-local derelict-enet-*/derelict-enet
dub remove-local derelict-util-*/derelict-util
@@ -61,7 +63,8 @@ check()
cd "${srcdir}/${_pkgname}"
_r=0
- # force an upgrade of the dependencies to the local folder, without --cache=local they get added to the users home directory
+ # force an upgrade of the dependencies to the local folder, without
+ # --cache=local they get added to the users home directory
dub upgrade --cache=local
# add local dependencies to search path
@@ -74,7 +77,8 @@ check()
dub test --cache=local || _r=$?
- # remove local dependencies from search path so dub don't find them later again
+ # remove local dependencies from search path so dub don't find them
+ # later again
dub remove-local allegro-*/allegro
dub remove-local derelict-enet-*/derelict-enet
dub remove-local derelict-util-*/derelict-util
@@ -92,16 +96,43 @@ check()
package()
{
cd "${srcdir}"
- install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # install application entry
+ install -Dm644 "${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
cd "${_pkgname}"
- install -Dm644 "data/images/${_pkgname}_logo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.svg"
- install -Dm644 "doc/copying.txt" "${pkgdir}/usr/share/licenses/${_pkgname}/COPYING"
+
+ # install application entry icon
+ install -Dm644 "data/images/${_pkgname}_logo.svg" \
+ "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.svg"
+
+ # install license text
+ install -Dm644 "doc/copying.txt" \
+ "${pkgdir}/usr/share/licenses/${_pkgname}/COPYING"
+
+ # install binary
install -Dm755 "bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- # https://lists.archlinux.org/pipermail/aur-general/2011-November/016777.html
- mkdir -p "${pkgdir}/usr/share/${_pkgname}" "${pkgdir}/usr/share/doc/${_pkgname}"
- cp -dpr --no-preserve=ownership "doc/." "${pkgdir}/usr/share/doc/${_pkgname}/"
- cp -dpr --no-preserve=ownership "data" "images" "levels" "${srcdir}/music" "${pkgdir}/usr/share/${_pkgname}"
+ # remove unimportant files
+ # https://raw.githubusercontent.com/SimonN/LixD/master/doc/build/package.txt
+ rm -r "${srcdir}/${_pkgname}/doc/build"
+
+ #https://lists.archlinux.org/pipermail/aur-general/2011-November/016777.html
+ # make directories
+ mkdir -p "${pkgdir}/usr/share/${_pkgname}" \
+ "${pkgdir}/usr/share/doc/${_pkgname}"
+
+ # copy documentary
+ cp -dpr --no-preserve=ownership "doc/." \
+ "${pkgdir}/usr/share/doc/${_pkgname}/"
+
+ # copy game files
+ cp -dpr --no-preserve=ownership \
+ "data" \
+ "images" \
+ "levels" \
+ "${srcdir}/music" \
+ "${pkgdir}/usr/share/${_pkgname}"
}
# template end;