summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG28
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
3 files changed, 32 insertions, 6 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index efcc27a72d47..d53746d1d5cc 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,32 @@
Version history
===============
+0.9.35
+------
+
+2020-12-24
+
+Undo/redo feature: The editor allows full undo and redo. Everything that is
+visible in the editor's level display is undoable: Tile moves, z-reorderings,
+additions, deletions, copying, rotations, mirroring, darkening, and changing
+the level's height, width, wrappings, and background color. Pressing the
+button to create a new level clears the undo history. Changing the level's
+name, lix, save requirement, player count, or skillset isn't undoable, but
+doesn't clear the undo history either; you can still undo earlier things.
+This undo/redo feature has been in development for 7 months.
+
+Fix #406: The camera rounds correctly to determine the mouse coordinates
+in the level. Before, with deep zoom, the mouse seemed to select things
+1 pixel too far right and 1 pixel too far down.
+
+Fix #405: The editor reinitializes its camera when the level's torus wrapping
+changes. This prevents graphical leftovers.
+
+Fixed compilation errors that appeared with DMD 2.094.2.
+
+Added build notes for a 64-bit Windows build with DMD. I encourage to use LDC
+instead of DMD for release builds, but it's good to have more options.
+
0.9.34
------
@@ -16,7 +42,7 @@ Skulls, Sludge and Steel - possible fix, needs checking.
(No fixes yet for Duality and Dream the impossible Dream.)
Fix #404: The 64-bit Windows enet.dll crashed on hosting a networking game.
-Now, I ship a new 64-bit enet.dll, version 1.3.13, that fixes the crash
+Now, I ship a new 64-bit enet.dll, version 1.3.12, that fixes the crash
on Windows, even though it still crashes in Wine.
Support 32-bit Windows again: I publish 32-bit Windows binaries in the github
diff --git a/.SRCINFO b/.SRCINFO
index 4e6350660dd4..8f14a113459b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.34
+ pkgver = 0.9.35
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,7 +14,7 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = liblphobos
- source = lix-0.9.34.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.34.tar.gz
+ source = lix-0.9.35.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.35.tar.gz
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
@@ -28,7 +28,7 @@ pkgbase = lix
source = lix-silly::git+https://gitlab.com/AntonMeep/silly.git#tag=v1.0.2
source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.18
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = 470902b93681887629dd287d7bb27bb55dd42831fc394c7f4a26de5d37460920156fae1dfc8ed6c3e311fb031f455f8accf38878b1fee928621f31d5ac56fcb1
+ sha512sums = 147e0a94640aea79c4c3205391a36d09af5403877dd9174115ec73717100142ad94cc0259308ff19d8cecceb87b0e16209aaa3bc586d6162b85d14c44aa57acc
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
sha512sums = 375b1439d9398371a3f58a92bfc0901b86bd89140aae431c7d9405bd2fb36ebcdb22b2686fea72d88b23a4ab94b138b4d742d8fd2965d8ec0542d2f8f64ed0c2
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b3a8d6a25efd..c9aaf1bcd14d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# shellcheck disable=SC2034,2154,2148
pkgname=lix
-pkgver=0.9.34
+pkgver=0.9.35
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz")
-sha512sums=('470902b93681887629dd287d7bb27bb55dd42831fc394c7f4a26de5d37460920156fae1dfc8ed6c3e311fb031f455f8accf38878b1fee928621f31d5ac56fcb1')
+sha512sums=('147e0a94640aea79c4c3205391a36d09af5403877dd9174115ec73717100142ad94cc0259308ff19d8cecceb87b0e16209aaa3bc586d6162b85d14c44aa57acc')
_gitname=LixD
pkgdesc="An action-puzzle game inspired by Lemmings"