summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG57
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
3 files changed, 61 insertions, 9 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 8808af1ed1e6..c2e18903f681 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,54 @@
Version history
===============
+0.9.5
+-----
+
+2017-12-13
+
+In NepsterLix/Moon, 10 levels got backroute fixes on 2017-11-30. All levels
+are proven solvable.
+
+In ClamLix/Outtakes, beautified Korean Border Crossing (version from
+2017-12-13) and Abridged Version v1. All levels remain solvable.
+
+Merged multiplayer maps by Arty: Blow Your Top, Shaft of Chaos, Showdown at
+Chainsaw Gap.
+
+Distinguished the pillars in matt/bricks from steel by yellow-brown color.
+Still to do: Distinguish pillars in geoo/construction from steel.
+
+Fix #272: Always draw splat ruler in front of terrain. Draw splat ruler even
+when it doesn't snap to anything.
+
+Fix #263, fix #269: Network game computes correct overtime when somebody
+nukes before saving lix, then saves some. This fixes crashes from assertion
+failures in the debugging build.
+
+Fix #209: The replay verifier called from the replay browser creates
+checkmarks when it finds solving replays whose player name matches the user's
+name. Command-line verification doesn't create any checkmarks.
+
+Fix #271: Verifier distinguishes normal failures without lix left from
+failures from running more than 5 minutes after the final skill assignment.
+
+Fix #157: Playing back winning replays on a wrong level version turned your
+correct checkmarks into '?!'. Now, replays will only affect checkmarks when
+the played level matches exactly.
+
+Fix #260: When you interrupt or modify a replay, then save it, your name
+replaces the old player name in the replay.
+
+Better key names on Windows when remapping hotkeys. If you still see keycode
+numbers instead of a proper key name, please tell me key and number.
+
+Translated leftover options to German: Sound and music volume, fast movement
+frees mouse, unpause on skill assignment.
+
+Fixed links in the build instructions that were still pointing to asdfasdf;
+they now point to lixgame.com.
+
+
0.9.4
-----
@@ -29,9 +77,11 @@ find a better solution.
Fix: Disable editor grid-size hotkey whenever an editor window is open.
-Fixed an assertion failure in the debugging build when dragging quickly in the editor.
+Fixed an assertion failure in the debugging build when dragging quickly in the
+editor.
-Fix #258: The multiplayer server crashed when somebody left, then the remaining players started a game. Still needs field testing.
+Fix #258: The multiplayer server crashed when somebody left, then the
+remaining players started a game. Still needs field testing.
0.9.3
-----
@@ -65,7 +115,8 @@ Cunning, Raindow Road down to Quirky.
Fix #252: Level search queries won't match the prefix 'levels/' in the
filenames because all levels would match.
-Fix #256: When you export levels to images or save replays manually, the button replacement will not say "done", but instead tell you the filename.
+Fix #256: When you export levels to images or save replays manually, the
+button replacement will not say "done", but instead tell you the filename.
Fix #254: When you run out of VRAM during a level, the game won't crash, but
instead stop making internal savestates. This won't display a warning, it will
diff --git a/.SRCINFO b/.SRCINFO
index 917137971e6a..d695555f11b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Nov 30 12:53:34 UTC 2017
+# Thu Dec 14 11:26:42 UTC 2017
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.4
+ pkgver = 0.9.5
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,8 +14,9 @@ pkgbase = lix
makedepends = dmd
makedepends = dub
depends = allegro
+ depends = enet
conflicts = lix-git
- source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.4
+ source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.5
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
sha512sums = SKIP
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
diff --git a/PKGBUILD b/PKGBUILD
index 4e334bab3817..ffcfb78fe97f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix
-pkgver=0.9.4
+pkgver=0.9.5
pkgrel=1
conflicts=("${pkgname}-git")
source=("${pkgname}::git+https://github.com/SimonN/LixD.git#tag=v${pkgver}"
@@ -19,13 +19,13 @@ prepare()
}
_pkgname=${pkgname}
-# template start; name=lix; version=0.2;
+# template start; name=lix; version=0.3;
pkgdesc="An action-puzzle game inspired by Lemmings"
arch=('i686' 'x86_64')
url="http://www.lixgame.com/"
license=('custom:CC0')
changelog=.CHANGELOG
-depends=('allegro')
+depends=('allegro' 'enet')
makedepends=('git' 'gendesk' 'dmd' 'dub')
build()