summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG40
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
3 files changed, 44 insertions, 5 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 35c626ee1d5c..d7bbfd42168e 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,9 +1,49 @@
Version history
===============
+0.9.9
+-----
+
+2018-01-22
+
+Added Arty's multiplayer maps: Knock 'em Dead, Pyramid Scheme, Pandemonium
+Box. Modified Rubix's Access Denied to make it completely symmetric.
+
+Fix #289: Replays that didn't point to levels, or even empty text files,
+crashed the replay browser on highlight.
+
+Fix #290: Fixed crash when running Lix from the quicklaunch bar on Windows.
+Allegro 5 has an issue where the Windows sound driver depends on an active
+display, and I assumed that the sound initialization would always succeed.
+I've reordered my initializations and display an error message, not crash, in
+case the sound driver still fails to initialize, which should be rare.
+
+Fix #288: Added optional program-wide hotkey to take a screenshot of the
+entire Lix window, saved in the export directory. No default keybinding.
+Plays disksave.ogg on screenshotting.
+
+Fix #291: Replay verifier called from the replay browser won't interrupt
+the main menu music.
+
+Fix #286: The player list in the multiplayer lobby won't draw over other parts
+of the window.
+
+The splat ruler isn't drawn while the mouse hovers over the panel. All three
+colored bars of the ruler are drawn at 80 % opacity, not 100 %, to keep
+terrain details visible behind. Activating splat ruler/exit ping doesn't play
+a sound effect anymore.
+
+Drew sunglasses icon and multiplayer nuke icon at scale 200 %.
+
+Savestates during game play clock.ogg, not disksave.ogg, because they aren't
+written to disk. disksave.ogg is always played quietly, not loudly, because
+the sound file is extremely loud already.
+
0.9.8
-----
+2018-01-15
+
lemforum: Lix Cannon, cover confusing gaps that were solid. Pipe Dream, remove
miners, improve lower route. Snow Jump, raise two pieces slightly.
diff --git a/.SRCINFO b/.SRCINFO
index 86bbd31ef73e..325d8344f4f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.8
+ pkgver = 0.9.9
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -11,9 +11,8 @@ pkgbase = lix
makedepends = dmd
makedepends = dub
depends = allegro
- depends = enet
conflicts = lix-git
- source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.8
+ source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.9
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6a6b655c3611..4d1b745bf444 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix
-pkgver=0.9.8
+pkgver=0.9.9
pkgrel=1
changelog=.CHANGELOG
conflicts=("${pkgname}-git")
@@ -19,7 +19,7 @@ pkgdesc="An action-puzzle game inspired by Lemmings"
arch=('i686' 'x86_64')
url="http://www.lixgame.com/"
license=('custom:CC0')
-depends=('allegro' 'enet')
+depends=('allegro')
makedepends=('git' 'dmd' 'dub')
build()