summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG35
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
3 files changed, 46 insertions, 3 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 463d00a164ed..b82e8d89dd8a 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,41 @@
Version history
===============
+0.9.13
+------
+
+2018-03-14
+
+Close to the Edge, save 46/50->16/20. Building Block Maze, SI 32->50. The
+Abominable Snowlix, save 15/30->5/10. Block Chaos, walkers 20->60, overtime
+1:00->2:00.
+
+Fix #312: Splat ruler option is now public. Choose one of three ruler designs.
+Default is the 3-bar ruler with huge snap distance from 0.9.5 to 0.9.10.
+
+Fix #308: Include Zanzindorf's lasers.
+
+Fix #305: Autosave 4 pairs of savestates, not 3, on most maps, for performant
+framestepping/multiplayer.
+
+Fix #55: Remove dialog on winning singleplayer. You go to the browser
+immediately after winning the level. Game pauses after losing, allowing you to
+framestep backwards or restart with the regular commands. I hope this
+satisfies the desire for a next-level button in the old dialog.
+
+Fix #302: Remove end-of-multiplayer dialog. You go to the lobby immediately after finishing a networking game. The lobby console shows the result, but I plan to show better statistics here. This fixes the bug where observers were shown instead of players in the end-of-multiplayer dialog.
+
+Fix #309: Show indexing progress of the search dialog. I still don't cache the
+search results; maybe the indexing feels still too slow on older computers
+even when its progress is shown.
+
+When you show FPS and Phyus, I don't display VRAM anymore. Reason: Once VRAM got cached on huge maps, the Lix-estimated VRAM usage didn't match the real VRAM usage anyway.
+
+New build dependency, Optional type. This is a source-only dependency and is
+automatically fetched by dub.
+
+Batch file to build Lix on Windows conveniently by double-clicking.
+
0.9.12
------
diff --git a/.SRCINFO b/.SRCINFO
index 7d8f7649b1ce..98575750cc1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.12
+ pkgver = 0.9.13
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -13,7 +13,7 @@ pkgbase = lix
depends = allegro
depends = enet
conflicts = lix-git
- source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.12
+ source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.13
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6ed5fdeba3dd..015379c0a628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix
-pkgver=0.9.12
+pkgver=0.9.13
pkgrel=1
changelog=.CHANGELOG
conflicts=("${pkgname}-git")
@@ -35,6 +35,8 @@ build()
dub add-local derelict-enet-*/derelict-enet
dub add-local derelict-util-*/derelict-util
dub add-local enumap-*/enumap
+ dub add-local optional-*/optional
+ dub add-local bolts-*/bolts
# force FHS compatibility with '-b releaseXDG'
dub build -f -b releaseXDG --cache=local || _r=$?
@@ -44,6 +46,8 @@ build()
dub remove-local derelict-enet-*/derelict-enet
dub remove-local derelict-util-*/derelict-util
dub remove-local enumap-*/enumap
+ dub remove-local optional-*/optional
+ dub remove-local bolts-*/bolts
dub clean-caches
if [[ "$_r" != 0 ]] ; then
@@ -65,6 +69,8 @@ check()
dub add-local derelict-enet-*/derelict-enet
dub add-local derelict-util-*/derelict-util
dub add-local enumap-*/enumap
+ dub add-local optional-*/optional
+ dub add-local bolts-*/bolts
dub test --cache=local || _r=$?
@@ -73,6 +79,8 @@ check()
dub remove-local derelict-enet-*/derelict-enet
dub remove-local derelict-util-*/derelict-util
dub remove-local enumap-*/enumap
+ dub remove-local optional-*/optional
+ dub remove-local bolts-*/bolts
dub clean-caches
if [[ "$_r" != 0 ]] ; then