summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG39
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
3 files changed, 44 insertions, 5 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 0aef475eae6e..34e075cca50e 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,45 @@
Version history
===============
+0.9.40
+------
+
+2021-12-13
+
+Added configurable hotkeys to play next levels from the end-of-singleplayer
+screen. Default is F1 to replay the same level, Space to play the next level,
+F to play the next unsolved level. There is no default hotkey to save the
+replay manually; you can configure it.
+
+Hotkey reminders on buttons are printed in slightly darker text. They're
+still brighter than the button itself, but darker than the main button text.
+
+Fix #417: The editor shows all teams per gadget. Example: 4 players A, B, C, D
+and the map has 2 exits. Before 0.9.40, the editor printed on the exits: A, B.
+Now, the editor print on the exits the outcome of distributing the 4 players
+round-robin to the exits: AC, BD.
+
+Clarify tile group names in the documentation doc/formats/level.txt: Groups
+can have any name, not necessarily only a number. Since I don't have support
+in the program for copying tile groups between levels, you can at least rename
+the groups in one level, e.g, by search-and-replace, then copy-paste them into
+the second level, and have no name clashes.
+
+Fixed exits order in Tunnel of Love 6p. There were 7 exits in a 6-player map,
+leading to apparent removal of a necessary exit in play. Now it has 6 exits.
+
+Added new multiplayer maps by Flopsy: The Lix and the Saboteurs 4p, 6p, 8p.
+
+Clarify documentation on tile groups in doc/format/level.txt: Tile groups
+can have any names. When you copy tile groups by hand between levels, you
+can first rename them with text replacement.
+
+Allow warnings when building Lix. This circumvents a warning in Phobos that
+would otherwise abort the build: Duplicate symbol for max!(int, int).max,
+_D3std9algorithm10comparison__T3maxTiTiZQjFNaNbNiNfiiZi.
+
+
+
0.9.39
------
diff --git a/.SRCINFO b/.SRCINFO
index 565da1ee9d15..4b685c06761a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.39
+ pkgver = 0.9.40
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,7 +14,7 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = liblphobos
- source = lix-0.9.39.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.39.tar.gz
+ source = lix-0.9.40.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.40.tar.gz
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
@@ -28,7 +28,7 @@ pkgbase = lix
source = lix-silly::git+https://gitlab.com/AntonMeep/silly.git#tag=v1.0.2
source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.22
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = 49895c78d892ee62fa6d40fc0c7c7377916cda494581eaf95b080558e6dee50c3b1298e9d94e72b9f7aa669f7303c7f4ce53692709dbcd6f040a000e0c0cf354
+ sha512sums = 26312fa3e1e2578f848769a446a4b0d59fdbd566cef87c8889a5f6ffb67192a60fb2f9285d03d7bd502e39b7882e87210e24a71ab07a6d9ede891bccce458cb1
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
sha512sums = 375b1439d9398371a3f58a92bfc0901b86bd89140aae431c7d9405bd2fb36ebcdb22b2686fea72d88b23a4ab94b138b4d742d8fd2965d8ec0542d2f8f64ed0c2
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 962daf3f3715..ebe167e0e7f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# shellcheck disable=SC2034,2154,2148
pkgname=lix
-pkgver=0.9.39
+pkgver=0.9.40
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz")
-sha512sums=('49895c78d892ee62fa6d40fc0c7c7377916cda494581eaf95b080558e6dee50c3b1298e9d94e72b9f7aa669f7303c7f4ce53692709dbcd6f040a000e0c0cf354')
+sha512sums=('26312fa3e1e2578f848769a446a4b0d59fdbd566cef87c8889a5f6ffb67192a60fb2f9285d03d7bd502e39b7882e87210e24a71ab07a6d9ede891bccce458cb1')
_gitname=LixD
pkgdesc="An action-puzzle game inspired by Lemmings"