summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG31
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
3 files changed, 40 insertions, 9 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 3a3e235786f6..efcc27a72d47 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,37 @@
Version history
===============
+0.9.34
+------
+
+2020-10-11
+
+lemforum: Backroute fixes for 6 levels, mainly due to Wibble's backroutes:
+Bipolar Maniac, initial lix 10->11, floaters 5->6.
+Las Ranas Hermanas, raise frogs.
+Triangle Inequality, eliminiate trivializing backroute.
+One Lix Showdown, likely functional but slightly unelegant fix.
+Some Like to Run, faster spawn interval, needs checking.
+Skulls, Sludge and Steel - possible fix, needs checking.
+(No fixes yet for Duality and Dream the impossible Dream.)
+
+Fix #404: The 64-bit Windows enet.dll crashed on hosting a networking game.
+Now, I ship a new 64-bit enet.dll, version 1.3.13, that fixes the crash
+on Windows, even though it still crashes in Wine.
+
+Support 32-bit Windows again: I publish 32-bit Windows binaries in the github
+releases and added linker flags for the 32-bit Windows DMD build in dub.json.
+
+Updated D source libraries in dub.json: derelict-enet 4.1.0 -> 4.2.0,
+taggedalgebraic 0.11.12 -> 0.11.18. This should have no visible effects.
+
+Credit minim in doc/thanks.txt for upscaling the GUI icons to 150%, 200%, 300%
+of the C++ Lix icons for 640x480 = 100%. minim worked on these icons in 2016.
+
+Remove doc/oldwish.txt, it has become outdated. The text is preserved at:
+https://www.lemmingsforums.net/index.php?topic=5132.0
+Let's file issues on github instead.
+
0.9.33
------
diff --git a/.SRCINFO b/.SRCINFO
index 01e4edc7452c..4e6350660dd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.33
+ pkgver = 0.9.34
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,21 +14,21 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = liblphobos
- source = lix-0.9.33.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.33.tar.gz
+ source = lix-0.9.34.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.34.tar.gz
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
source = lix-bolts::git+https://github.com/aliak00/bolts.git#tag=v0.7.1
- source = lix-derelict-enet::git+https://github.com/DerelictOrg/DerelictENet.git#tag=v4.1.0
+ source = lix-derelict-enet::git+https://github.com/DerelictOrg/DerelictENet.git#tag=v4.2.0
source = lix-derelict-util::git+https://github.com/DerelictOrg/DerelictUtil.git#tag=v3.0.0-beta.2
source = lix-enumap::git+https://github.com/rcorre/enumap.git#tag=v0.4.2
source = lix-libinputvisitor::git+https://github.com/Abscissa/libInputVisitor.git#tag=v1.2.2
source = lix-optional::git+https://github.com/aliak00/optional.git#tag=v0.6.3
source = lix-sdlang-d::git+https://github.com/Abscissa/SDLang-D.git#tag=v0.10.6
source = lix-silly::git+https://gitlab.com/AntonMeep/silly.git#tag=v1.0.2
- source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.12
+ source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.18
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = 0a9c8b1eb7cce8c69ed51bb8f34a98000d9b25bb342cbd444b01c37f41878b9b62c9880dbc4fb0d6bd77072512ebec771fd48248aba809a4dd47b5b0d84fbe0c
+ sha512sums = 470902b93681887629dd287d7bb27bb55dd42831fc394c7f4a26de5d37460920156fae1dfc8ed6c3e311fb031f455f8accf38878b1fee928621f31d5ac56fcb1
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
sha512sums = 375b1439d9398371a3f58a92bfc0901b86bd89140aae431c7d9405bd2fb36ebcdb22b2686fea72d88b23a4ab94b138b4d742d8fd2965d8ec0542d2f8f64ed0c2
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 791d206ac75a..b3a8d6a25efd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# shellcheck disable=SC2034,2154,2148
pkgname=lix
-pkgver=0.9.33
+pkgver=0.9.34
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz")
-sha512sums=('0a9c8b1eb7cce8c69ed51bb8f34a98000d9b25bb342cbd444b01c37f41878b9b62c9880dbc4fb0d6bd77072512ebec771fd48248aba809a4dd47b5b0d84fbe0c')
+sha512sums=('470902b93681887629dd287d7bb27bb55dd42831fc394c7f4a26de5d37460920156fae1dfc8ed6c3e311fb031f455f8accf38878b1fee928621f31d5ac56fcb1')
_gitname=LixD
pkgdesc="An action-puzzle game inspired by Lemmings"
@@ -18,14 +18,14 @@ depends=('allegro' 'enet' 'hicolor-icon-theme' 'liblphobos')
makedepends=('git' 'ldc' 'dub')
_dubv=( "4.0.4+5.2.0" # allegro
"0.7.1" # bolts
- "4.1.0" # derelict-enet
+ "4.2.0" # derelict-enet
"3.0.0-beta.2" # derelict-util
"0.4.2" # enumap
"1.2.2" # libinputvisitor
"0.6.3" # optional
"0.10.6" # sdlang-d
"1.0.2" # silly
- "0.11.12" # taggedalgebraic
+ "0.11.18" # taggedalgebraic
"0.7.55" # unit-threaded
)