summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1793305c7ae4..8db55a303f2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lizard-git
pkgdesc = An efficient compressor with very fast decompression
- pkgver = 1.0.r3.g6a1ed71
+ pkgver = 1.0.r9.gaf8518c
pkgrel = 1
url = https://github.com/inikep/lizard
arch = i686
@@ -9,10 +9,9 @@ pkgbase = lizard-git
license = BSD
makedepends = git
depends = glibc
- provides = lizard
+ provides = lizard=1.0.r9.gaf8518c
conflicts = lizard
source = git+https://github.com/inikep/lizard.git
sha256sums = SKIP
pkgname = lizard-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b317c201d5e2..f6863401f742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=lizard-git
-pkgver=1.0.r3.g6a1ed71
+pkgver=1.0.r9.gaf8518c
pkgrel=1
pkgdesc="An efficient compressor with very fast decompression"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://github.com/inikep/lizard"
license=('GPL2' 'BSD')
depends=('glibc')
makedepends=('git')
-provides=('lizard')
+provides=("lizard=$pkgver")
conflicts=('lizard')
source=("git+https://github.com/inikep/lizard.git")
sha256sums=('SKIP')
@@ -36,6 +36,9 @@ check() {
package() {
cd "lizard"
- make DESTDIR="$pkgdir" PREFIX="/usr" install
- install -Dm644 "lib/LICENSE" "$pkgdir/usr/share/licenses/lizard/LICENSE"
+ make \
+ DESTDIR="$pkgdir" \
+ PREFIX="/usr" \
+ install
+ install -Dm644 "lib/LICENSE" -t "$pkgdir/usr/share/licenses/lizard"
}