summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 22 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b5f1cf3f368..fa02b1a5a6a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 14.0.0_r413047.c703d77a61ac
+ pkgver = 18.0.0_r484887.953ae94149f0
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -12,8 +12,7 @@ pkgbase = llvm-git
makedepends = libedit
makedepends = ncurses
makedepends = libxml2
- makedepends = python-sphinx
- makedepends = python-sphinx-automodapi
+ makedepends = python-setuptools
makedepends = lldb
makedepends = ocaml
makedepends = ocaml-ctypes
@@ -23,11 +22,13 @@ pkgbase = llvm-git
makedepends = swig
makedepends = python
makedepends = python-six
+ makedepends = python-myst-parser
makedepends = lua53
makedepends = ocl-icd
makedepends = opencl-headers
makedepends = z3
makedepends = jsoncpp
+ makedepends = ocaml-stdlib-shims
options = staticlibs
source = llvm-project::git+https://github.com/llvm/llvm-project.git
source = llvm-config.h
@@ -38,10 +39,9 @@ pkgbase = llvm-git
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=14.0.0_r413047.c703d77a61ac-1
+ depends = llvm-libs-git=18.0.0_r484887.953ae94149f0-1
depends = perl
optdepends = python: for scripts
- optdepends = python-setuptools: for using lit = LLVM Integrated Tester
provides = aur-llvm-git
provides = compiler-rt-git
provides = clang-git
@@ -77,7 +77,7 @@ pkgname = llvm-libs-git
pkgname = llvm-ocaml-git
pkgdesc = OCaml bindings for LLVM
- depends = llvm-git=14.0.0_r413047.c703d77a61ac-1
+ depends = llvm-git=18.0.0_r484887.953ae94149f0-1
depends = ocaml
depends = ocaml-ctypes
provides = llvm-ocaml
diff --git a/PKGBUILD b/PKGBUILD
index 4449fd6951bf..ea8886870aee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,15 +16,16 @@
pkgname=('llvm-git' 'llvm-libs-git' 'llvm-ocaml-git')
-pkgver=14.0.0_r413047.c703d77a61ac
+pkgver=19.0.0_r495959.9f3334e9932f
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
license=('custom:Apache 2.0 with LLVM Exception')
-makedepends=('git' 'cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2' 'python-sphinx'
- 'python-sphinx-automodapi' 'lldb' 'ocaml' 'ocaml-ctypes' 'ocaml-findlib'
- 'python-sphinx' 'python-recommonmark' 'swig' 'python' 'python-six' 'lua53'
- 'ocl-icd' 'opencl-headers' 'z3' 'jsoncpp')
+makedepends=('git' 'cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2'
+ 'python-setuptools' 'lldb' 'ocaml' 'ocaml-ctypes' 'ocaml-findlib'
+ 'python-sphinx' 'python-recommonmark' 'swig' 'python' 'python-six'
+ 'python-myst-parser' 'lua53' 'ocl-icd' 'opencl-headers' 'z3'
+ 'jsoncpp' 'ocaml-stdlib-shims')
checkdepends=("python-psutil")
source=("llvm-project::git+https://github.com/llvm/llvm-project.git"
"llvm-config.h")
@@ -46,7 +47,7 @@ _python_optimize() {
}
pkgver() {
- cd llvm-project/llvm
+ cd llvm-project/cmake/Modules
# This will almost match the output of `llvm-config --version` when the
# LLVM_APPEND_VC_REV cmake flag is turned on. The only difference is
@@ -55,12 +56,11 @@ pkgver() {
'BEGIN { ORS="." ; i=0 } \
/set\(LLVM_VERSION_/ { print $2 ; i++ ; if (i==2) ORS="" } \
END { print "\n" }' \
- CMakeLists.txt)_r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ LLVMVersion.cmake)_r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
echo "$_pkgver"
}
build() {
-
export CFLAGS+=" ${CPPFLAGS}"
export CXXFLAGS+=" ${CPPFLAGS}"
cmake \
@@ -88,6 +88,7 @@ build() {
-D LLDB_USE_SYSTEM_SIX=1 \
-D LLVM_ENABLE_PROJECTS="polly;lldb;lld;compiler-rt;clang-tools-extra;clang" \
-D LLVM_LIT_ARGS="-sv --ignore-fail" \
+ -D LLVM_ENABLE_DUMP=ON \
-Wno-dev
ninja -C _build $NINJAFLAGS
@@ -106,21 +107,19 @@ check() {
package_llvm-git() {
pkgdesc="LLVM development version. includes clang and many other tools"
depends=("llvm-libs-git=$pkgver-$pkgrel" 'perl')
- optdepends=('python: for scripts'
- 'python-setuptools: for using lit = LLVM Integrated Tester'
- )
+ optdepends=('python: for scripts')
provides=(aur-llvm-git compiler-rt-git clang-git lldb-git lld-git polly-git
llvm compiler-rt clang lldb polly lld )
# A package always provides itself, so there's no need to provide llvm-git
conflicts=('llvm' 'compiler-rt' 'clang' 'lldb' 'polly' 'lld')
-
+
DESTDIR="$pkgdir" ninja -C _build $NINJAFLAGS install
# Include lit for running lit-based tests in other projects
pushd llvm-project/llvm/utils/lit
python setup.py install --root="$pkgdir" -O1
popd
-
+
# Move analyzer scripts out of /usr/libexec
mv "$pkgdir"/usr/libexec/{ccc,c++}-analyzer "$pkgdir"/usr/lib/clang/
mv "$pkgdir"/usr/libexec/analyze-{cc,c++} "$pkgdir"/usr/lib/clang/
@@ -142,7 +141,7 @@ package_llvm-git() {
else
mv "$pkgdir"/usr/share/doc/llvm/ocaml-html "$srcdir"/ocaml.doc
fi
-
+
if [[ $CARCH == x86_64 ]]; then
# Needed for multilib (https://bugs.archlinux.org/task/29951)
# Header stub is taken from Fedora
@@ -150,10 +149,9 @@ package_llvm-git() {
cp "$srcdir"/llvm-config.h "$pkgdir"/usr/include/llvm/Config/llvm-config.h
fi
- _py="3.10"
+ _py=$([[ "$(python -V)" =~ Python[[:space:]]*([0-9]+.[0-9]+) ]] && echo ${BASH_REMATCH[1]})
cd llvm-project
# Install Python bindings and optimize them
- cp -a llvm/bindings/python/llvm "$pkgdir"/usr/lib/python$_py/site-packages/
cp -a clang/bindings/python/clang "$pkgdir"/usr/lib/python$_py/site-packages/
_python_optimize "$pkgdir"/usr/lib/python$_py/site-packages
@@ -185,7 +183,7 @@ package_llvm-libs-git() {
# https://bugs.archlinux.org/task/28479
install -d "$pkgdir"/usr/lib/bfd-plugins
ln -s ../LLVMgold.so "$pkgdir"/usr/lib/bfd-plugins/LLVMgold.so
-
+
cd llvm-project/
install -Dm644 llvm/LICENSE.TXT "$pkgdir"/usr/share/licenses/$pkgname/llvm-LICENSE
install -Dm644 clang/LICENSE.TXT "$pkgdir"/usr/share/licenses/$pkgname/clang-LICENSE
@@ -201,7 +199,7 @@ package_llvm-ocaml-git() {
depends=("llvm-git=$pkgver-$pkgrel" "ocaml" 'ocaml-ctypes')
conflicts=('llvm-ocaml')
provides=("llvm-ocaml")
-
+
install -d "$pkgdir"/{usr/lib,usr/share/doc/$pkgname}
cp -a "$srcdir"/ocaml.lib "$pkgdir"/usr/lib/ocaml
cp -a "$srcdir"/ocaml.doc "$pkgdir"/usr/share/doc/$pkgname/html