summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c555dd4933c5..4b5f1cf3f368 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 14.0.0_r407312.ef5be2bb16e5
+ pkgver = 14.0.0_r413047.c703d77a61ac
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -38,7 +38,7 @@ pkgbase = llvm-git
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=14.0.0_r407312.ef5be2bb16e5-1
+ depends = llvm-libs-git=14.0.0_r413047.c703d77a61ac-1
depends = perl
optdepends = python: for scripts
optdepends = python-setuptools: for using lit = LLVM Integrated Tester
@@ -77,7 +77,7 @@ pkgname = llvm-libs-git
pkgname = llvm-ocaml-git
pkgdesc = OCaml bindings for LLVM
- depends = llvm-git=14.0.0_r407312.ef5be2bb16e5-1
+ depends = llvm-git=14.0.0_r413047.c703d77a61ac-1
depends = ocaml
depends = ocaml-ctypes
provides = llvm-ocaml
diff --git a/PKGBUILD b/PKGBUILD
index f860531c5927..4449fd6951bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgname=('llvm-git' 'llvm-libs-git' 'llvm-ocaml-git')
-pkgver=14.0.0_r407313.15f8f3e20aa9
+pkgver=14.0.0_r413047.c703d77a61ac
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -87,6 +87,7 @@ build() {
-D POLLY_ENABLE_GPGPU_CODEGEN=ON \
-D LLDB_USE_SYSTEM_SIX=1 \
-D LLVM_ENABLE_PROJECTS="polly;lldb;lld;compiler-rt;clang-tools-extra;clang" \
+ -D LLVM_LIT_ARGS="-sv --ignore-fail" \
-Wno-dev
ninja -C _build $NINJAFLAGS
@@ -134,7 +135,13 @@ package_llvm-git() {
# OCaml bindings go to a separate package
rm -rf "$srcdir"/ocaml.{lib,doc}
mv "$pkgdir"/usr/lib/ocaml "$srcdir"/ocaml.lib
- mv "$pkgdir"/usr/share/doc/llvm/ocaml-html "$srcdir"/ocaml.doc
+
+ if [[ -d "${pkgdir}/usr/share/doc/LLVM/llvm/ocaml-html" && ! -d "${pkgdir}/usr/share/doc/llvm/ocaml-html" ]]
+ then
+ mv "$pkgdir"/usr/share/doc/LLVM/llvm/ocaml-html "$srcdir"/ocaml.doc
+ else
+ mv "$pkgdir"/usr/share/doc/llvm/ocaml-html "$srcdir"/ocaml.doc
+ fi
if [[ $CARCH == x86_64 ]]; then
# Needed for multilib (https://bugs.archlinux.org/task/29951)