summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2151cf8f8ff1..44127275a7b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,7 +77,8 @@ _py_sitepkg_dir="/usr/lib/python2.7/site-packages"
# Determine the installed OCaml package version
# Arguments: NONE
_ocamlver() {
- pacman -Q ocaml | awk '{ print $2 }' | cut -d - -f 1 | cut -d . -f 1,2,3
+ { pacman -Q ocaml 2>/dev/null || echo 'ocaml 0.0.0-0' ;} \
+ | awk '{ print $2 }' | cut -d - -f 1 | cut -d . -f 1,2,3
}
# Fix the Python interpreter path in .py files to point to python2