summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 31 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b45f6438e16..b90a9ae81f83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = logcat-color3
pkgdesc = A colorful and highly configurable alternative to the standard "adb logcat" command from the Android SDK
- pkgver = 0.9.0
- pkgrel = 3
+ pkgver = 0.10.0
+ pkgrel = 1
url = https://github.com/yan12125/logcat-color3
arch = any
license = Apache
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-setuptools-scm
+ makedepends = python-wheel
+ depends = python
depends = python-colorama
conflicts = logcat-color
- source = https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-0.9.0.tar.gz
- source = https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-0.9.0.tar.gz.asc
- validpgpkeys = 481C4474AF1572165AE4C6AF3FDDD575826C5C30
- sha256sums = 57471841b59d0a456f6d3a971bb3701ca2fc9a8319735e9515c9de3cd2062c92
+ source = git+https://github.com/yan12125/logcat-color3?signed#tag=ee5c73183b4ab58e0103bddbe1119632ce43e500
+ validpgpkeys = E62545315B012B69C8C94A1D56EC201BFC794362
sha256sums = SKIP
pkgname = logcat-color3
-
diff --git a/PKGBUILD b/PKGBUILD
index f2bb4126b4aa..f4e2489a8c36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,40 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Maintainer: Chih-Hsuan Yen <base64_decode("eXUzYWN0eHQydHR0ZmlteEBjaHllbi5jYwo=")>
# Contributor: Thomas Weißschuh <thomas t-8ch de>
pkgname=logcat-color3
-pkgver=0.9.0
-pkgrel=3
+pkgver=0.10.0
+# curl https://api.github.com/repos/yan12125/logcat-color3/git/ref/tags/v$pkgver | jq -r .object.sha
+_tag=ee5c73183b4ab58e0103bddbe1119632ce43e500
+pkgrel=1
pkgdesc='A colorful and highly configurable alternative to the standard "adb logcat" command from the Android SDK'
arch=(any)
url='https://github.com/yan12125/logcat-color3'
license=(Apache)
-depends=(python-colorama)
-makedepends=(python-setuptools-scm)
+depends=(python python-colorama)
+makedepends=(git python-build python-installer python-setuptools python-setuptools-scm python-wheel)
conflicts=(logcat-color)
-source=("https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-$pkgver.tar.gz"{,.asc})
-sha256sums=('57471841b59d0a456f6d3a971bb3701ca2fc9a8319735e9515c9de3cd2062c92'
- 'SKIP')
+source=("git+https://github.com/yan12125/logcat-color3?signed#tag=$_tag")
+sha256sums=('SKIP')
validpgpkeys=(
- '481C4474AF1572165AE4C6AF3FDDD575826C5C30' # Chih-Hsuan Yen <yan12125@gmail.com>
+ 'E62545315B012B69C8C94A1D56EC201BFC794362'
)
+pkgver() {
+ cd logcat-color3
+ git describe --tags | sed 's/^v//'
+}
+
build() {
- cd logcat-color3-$pkgver
- python setup.py build
+ cd logcat-color3
+ python -m build --wheel --no-isolation
}
check() {
- cd logcat-color3-$pkgver
- python test/test.py
+ cd logcat-color3
+ python -m unittest discover ./test
}
package() {
- cd logcat-color3-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd logcat-color3
+ python -m installer --destdir="$pkgdir" dist/*.whl
}