summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b37eb897916f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = logic-synthesis-bin
+ pkgdesc = Logic synthesis system from UC Berkeley.
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://jackhack96.github.io/logic-synthesis
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = bison
+ makedepends = flex
+ depends = readline
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/JackHack96/logic-synthesis/archive/SIS.tar.gz
+ md5sums = 7b9a5086603a5aa32fdbbfd5618f64e8
+
+pkgname = logic-synthesis-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cd89a9789a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Joshua Chapman <john.chy99@gmail.com>
+pkgname=logic-synthesis-bin
+pkgver=1.4
+pkgrel=1
+epoch=
+pkgdesc="Logic synthesis system from UC Berkeley."
+arch=('i686' 'x86_64')
+url="https://jackhack96.github.io/logic-synthesis"
+license=('BSD')
+groups=()
+depends=('readline')
+makedepends=('bison' 'flex')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=('!strip' '!emptydirs')
+install=
+changelog=
+source=("https://github.com/JackHack96/logic-synthesis/archive/SIS.tar.gz")
+noextract=()
+md5sums=('7b9a5086603a5aa32fdbbfd5618f64e8')
+validpgpkeys=()
+
+build() {
+ cd "$srcdir/logic-synthesis-SIS"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/logic-synthesis-SIS"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/logic-synthesis-SIS"
+ make DESTDIR="$pkgdir/" install
+}