summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5339fe8f1fce..affdbadd1918 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = logseq-desktop-bin
pkgdesc = Privacy-first, open-source platform for knowledge sharing and management
- pkgver = 0.10.7
+ pkgver = 0.10.9
pkgrel = 1
url = https://github.com/logseq/logseq
install = logseq-desktop.install
arch = x86_64
license = AGPL-3.0-or-later
makedepends = gendesk
- provides = logseq-desktop=0.10.7
+ provides = logseq-desktop=0.10.8
conflicts = logseq-desktop
options = !debug
options = !strip
- source = https://github.com/logseq/logseq/releases/download/0.10.7/Logseq-linux-x64-0.10.7.zip
+ source = https://github.com/logseq/logseq/releases/download/0.10.8/Logseq-linux-x64-0.10.8.zip
sha256sums = SKIP
pkgname = logseq-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8a4f208682e3..a875e8f222e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,10 @@ fi
: ${_install_path:=opt}
-unset _pkgtype
-: ${_pkgtype:=-bin}
-
# basic info
_pkgname="logseq-desktop"
-pkgname="$_pkgname${_pkgtype:-}"
-pkgver=0.10.7
+pkgname="$_pkgname-bin"
+pkgver=0.10.9
pkgrel=1
pkgdesc="Privacy-first, open-source platform for knowledge sharing and management"
url="https://github.com/logseq/logseq"
@@ -48,7 +45,7 @@ _main_package() {
# common functions
pkgver() {
- printf '%s' "${_pkgver:?}"
+ echo "${_pkgver:?}"
}
prepare() {
@@ -139,15 +136,9 @@ _update_version() {
return
fi
- _response=$(curl -Ssf "$url/releases.atom")
-
- _pkgver_new=$(
- printf '%s' "$_response" \
- | grep '/releases/tag/' \
- | sed -E 's@^.*/releases/tag/(.*)".*$@\1@' \
- | grep -Ev '[a-z]{2}' | sort -V | tail -1
- )
-
+ _response=$(curl -SsfL "https://api.github.com/repos/logseq/logseq/releases/latest")
+ _pkgver_new=$(printf '%s' "$_response" | grep -oP '"tag_name": "\K(.*?)(?=")')
+
# update _pkgver
if [ "$_pkgver" != "${_pkgver_new:?}" ] ; then
_pkgver="${_pkgver_new:?}"