summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO6
-rw-r--r--ChangeLog17
-rw-r--r--Jenkinsfile96
-rwxr-xr-xPKGBUILD4
4 files changed, 103 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe60ea85a0bc..cbbc0c07ebbe 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = logstash
pkgdesc = Transport and process your logs, events, or other data
- pkgver = 8.12.2
+ pkgver = 8.14.0
pkgrel = 1
url = https://www.elastic.co/logstash/
changelog = ChangeLog
@@ -19,13 +19,13 @@ pkgbase = logstash
backup = etc/logstash/log4j2.properties
backup = etc/logstash/logstash.yml
backup = etc/logstash/pipelines.yml
- source = https://github.com/elastic/logstash/archive/v8.12.2/logstash-8.12.2.tar.gz
+ source = https://github.com/elastic/logstash/archive/v8.14.0/logstash-8.14.0.tar.gz
source = logstash.service
source = logstash@.service
source = logstash-sysuser.conf
source = logstash-tmpfile.conf
source = bundle.config
- md5sums = 8b3a565618a8a5703053c94fcbfe31f6
+ md5sums = 3c81a2d273e61a9f94a94b5ba7055a50
md5sums = 4c3efce8ba4da2605c1f2e839e3af55c
md5sums = 54523d10c53cf5461a40a33d775c12c1
md5sums = 7ef5efbe99cf9f4c29a221999ec41248
diff --git a/ChangeLog b/ChangeLog
index 54b3641ed3ca..f927d2f16322 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,15 +1,2 @@
-=Logstash 8.12.2 Release Notes
-
- Set Netty’s maxOrder options to previous default value of 11 #15928
- Add "openssl" to UBI docker images #15929
-
-Plugins
-
-Jdbc Integration - 5.4.8
-
- Update Derby to 10.15.2.1 (built from source) #155
- Update sequel version to >= 5.74.0, that allows the generic jdbc adapter to better handle disconnect errors #153
-
-Kafka Integration - 11.3.4
-
- Fix "retries" and "value_serializer" error handling in output plugin #160
+Downloads: https://www.elastic.co/downloads/logstash
+Release notes: https://www.elastic.co/guide/en/logstash/8.14/logstash-8-14-0.html
diff --git a/Jenkinsfile b/Jenkinsfile
new file mode 100644
index 000000000000..ab05460a66ed
--- /dev/null
+++ b/Jenkinsfile
@@ -0,0 +1,96 @@
+/* groovylint-disable GStringExpressionWithinString, LineLength */
+pipeline {
+ agent any
+ environment {
+ VERSION = """${sh(
+ returnStdout: true,
+ script: "curl https://api.github.com/repos/elastic/logstash/releases/latest | jq -r '.tag_name' | cut -c2- | tr -d '\n'"
+ )}"""
+ }
+ stages {
+ stage('Checkout') {
+ steps {
+ checkout scm
+ }
+ }
+ stage('Update PKGBUILD') {
+ steps {
+ sh '''
+ sed -ie "s|pkgver=.*$|pkgver=${VERSION}|g" PKGBUILD
+ rm PKGBUILDe
+ '''
+ }
+ }
+ stage('Update Checksums') {
+ steps {
+ sh '''
+ updpkgsums
+ '''
+ }
+ }
+ stage('Make Package') {
+ steps {
+ sh '''
+ makepkg -s
+ '''
+ }
+ }
+ stage('Get Changelog') {
+ steps {
+ sh '''
+ curl https://api.github.com/repos/elastic/logstash/releases/latest | jq -r '.body' > ChangeLog
+ '''
+ }
+ }
+ stage('Generate .SRCINFO') {
+ steps {
+ sh '''
+ makepkg --printsrcinfo > .SRCINFO
+ '''
+ }
+ }
+ stage('Cleanup - makepkg Artifacts') {
+ steps {
+ sh '''
+ rm -rf pkg src logstash-8*
+ '''
+ }
+ }
+ stage('Git Push') {
+ steps {
+ withCredentials([sshUserPrivateKey(credentialsId: "Arch_AUR", keyFileVariable: 'KEY')]) {
+ sh '''
+ git config user.email "aman.iv0012@gmail.com"
+ git config user.name "Aman Gupta"
+ export GIT_SSH_COMMAND="ssh -o StrictHostKeyChecking=no -i $KEY"
+ git branch release
+ git checkout master
+ git merge release
+ git remote add ssh-origin ssh://aur@aur.archlinux.org/logstash.git
+ git commit -am "Automated Release: Updated to v${VERSION}"
+ git push ssh-origin master
+ '''
+ }
+ }
+ }
+ }
+ post {
+ always {
+ deleteDir() /* clean up our workspace */
+ }
+ success {
+ withCredentials([string(credentialsId: 'Discord_Webhook', variable: 'WEBHOOK_URL')]) {
+ sh '''
+ curl -H 'Content-Type: application/json' -d '{\"content\": \"✅ Logstash v'"$VERSION"' Released to AUR 🎆\"}' ${WEBHOOK_URL}
+ '''
+ }
+ }
+ failure {
+ withCredentials([string(credentialsId: 'Discord_Webhook', variable: 'WEBHOOK_URL')]) {
+ sh '''
+ curl -H 'Content-Type: application/json' -d '{\"content\": \"❌ Logstash v'"$VERSION"' Pipeline Failed 🛠️\"}' ${WEBHOOK_URL}
+ '''
+ }
+ }
+ }
+}
diff --git a/PKGBUILD b/PKGBUILD
index 2aa0d964e900..a1ed70ae4618 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Aman Gupta <aman.iv0012@gmail.com>
pkgname=logstash
-pkgver=8.12.2
+pkgver=8.14.0
pkgrel=1
pkgdesc="Transport and process your logs, events, or other data"
arch=('x86_64')
@@ -28,7 +28,7 @@ source=(https://github.com/elastic/logstash/archive/v${pkgver}/${pkgname}-${pkgv
logstash-tmpfile.conf
bundle.config)
# noextract=()
-md5sums=('8b3a565618a8a5703053c94fcbfe31f6'
+md5sums=('3c81a2d273e61a9f94a94b5ba7055a50'
'4c3efce8ba4da2605c1f2e839e3af55c'
'54523d10c53cf5461a40a33d775c12c1'
'7ef5efbe99cf9f4c29a221999ec41248'